aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-filesystems/COPYING.MIT17
-rw-r--r--meta-filesystems/README138
-rw-r--r--meta-filesystems/conf/layer.conf10
3 files changed, 165 insertions, 0 deletions
diff --git a/meta-filesystems/COPYING.MIT b/meta-filesystems/COPYING.MIT
new file mode 100644
index 0000000000..89de354795
--- /dev/null
+++ b/meta-filesystems/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/meta-filesystems/README b/meta-filesystems/README
new file mode 100644
index 0000000000..d2716f8f1f
--- /dev/null
+++ b/meta-filesystems/README
@@ -0,0 +1,138 @@
+This README file contains information on the contents of the
+filesystems layer.
+
+Please see the corresponding sections below for details.
+
+
+Dependencies
+============
+
+This layer depends on:
+
+ URI: git://git.openembedded.org/bitbake
+ branch: master
+
+ URI: git://git.openembedded.org/openembedded-core
+ layers: meta
+ branch: master
+
+ URI: git://git.openembedded.org/meta-openembedded
+ layers: meta-oe
+ branch: master
+
+Patches
+=======
+
+Please submit any patches against the filesystems layer to the
+OpenEmbedded development mailing list (openembedded-devel@lists.openembedded.org)
+with '[meta-filesystems]' in the subject.
+
+Maintainers List:
+ physfs Andreas Müller <schnitzeltony@googlemail.com>
+
+ fuse Koen Kooi <koen@dominion.thruhere.net>
+ Philip Balister <philip@balister.org>
+ hongxu jia <hongxu.jia@windriver.com>
+
+ ifuse Sander van Grieken <sander@outrightsolutions.nl>
+ Koen Kooi <koen@dominion.thruhere.net>
+
+ sshfs-fuse Philip Balister <philip@balister.org>
+ Koen Kooi <koen@dominion.thruhere.net>
+
+ owfs Otavio Salvador <otavio@ossystems.com.br>
+ Koen Kooi <koen@dominion.thruhere.net>
+ hongxu jia <hongxu.jia@windriver.com>
+
+ ntfs-3g-ntfsprogs Otavio Salvador <otavio@ossystems.com.br>
+ hongxu jia <hongxu.jia@windriver.com>
+
+ cramfs Koen Kooi <koen@dominion.thruhere.net>
+
+ smbnetfs Sander van Grieken <sander@outrightsolutions.nl>
+ Koen Kooi <koen@dominion.thruhere.net>
+
+ fuse-exfat hongxu jia <hongxu.jia@windriver.com>
+
+ exfat-utils hongxu jia <hongxu.jia@windriver.com>
+
+ f2fs-tools Martin Jansa <Martin.Jansa@gmail.com>
+ Koen Kooi <koen@dominion.thruhere.net>
+
+ xfsprogs Koen Kooi <koen@dominion.thruhere.net>
+ hongxu jia <hongxu.jia@windriver.com>
+
+When sending single patches, please use something like:
+
+ git send-email -1 -M \
+ --to openembedded-devel@lists.openembedded.org \
+ --subject-prefix=meta-filesystems][PATCH
+
+
+Table of Contents
+=================
+
+ I. Adding the filesystems layer to your build
+ II. Misc
+
+
+I. Adding the filesystems layer to your build
+=================================================
+
+In order to use this layer, you need to make the build system aware of
+it.
+
+Assuming the filesystems layer exists at the top-level of your
+yocto build tree, you can add it to the build system by adding the
+location of the filesystems layer to bblayers.conf, along with any
+other layers needed. e.g.:
+
+ BBLAYERS ?= " \
+ /path/to/yocto/meta \
+ /path/to/yocto/meta-oe \
+ /path/to/yocto/meta-filesystems \
+ "
+
+
+II. Misc
+========
+
+ --- physfs ---
+ A library to provide abstract access to various archives
+
+ --- fuse ---
+ Filesystem in Userspace (FUSE) is a simple interface for userspace programs
+ to export a virtual filesystem to the Linux kernel.
+
+ --- ifuse ---
+ A fuse filesystem to access the contents of an iPhone or iPod Touch
+
+ --- sshfs-fuse ---
+ A filesystem client based on the SSH File Transfer Protocol
+
+ --- owfs ---
+ An easy way to use the 1-Wire file system
+
+ --- ntfs-3g-ntfsprogs ---
+ The ntfs-3g is a freely available read/write NTFS driver for Linux and
+ ntfsprogs includes utilities for doing all required tasks to NTFS partitions.
+
+ --- cramfs ---
+ Builds cramfs filesystems for embedded systems
+
+ --- smbnetfs ---
+ SMBNetFS is a Linux/FreeBSD filesystem that allow you to use samba/microsoft
+ network in the same manner as the network neighborhood in Microsoft Windows.
+
+ --- fuse-exfat ---
+ A read and write exFAT driver for FUSE
+
+ --- exfat-utils ---
+ Utilities to create, check, label and dump exFAT filesystem
+
+ --- f2fs-tools ---
+ Tools needed for creating and managing f2fs partitions
+
+ --- xfsprogs ---
+ It provides XFS filesystem utilities.
+
diff --git a/meta-filesystems/conf/layer.conf b/meta-filesystems/conf/layer.conf
new file mode 100644
index 0000000000..c0bbd78216
--- /dev/null
+++ b/meta-filesystems/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "filesystems-layer"
+BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/"
+BBFILE_PRIORITY_filesystems-layer = "6"