aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-werkzeug.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-werkzeug_0.11.10.bb2
2 files changed, 14 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-werkzeug.inc b/meta-python/recipes-devtools/python/python-werkzeug.inc
index f6f75d0ca7..e30c80b0e2 100644
--- a/meta-python/recipes-devtools/python/python-werkzeug.inc
+++ b/meta-python/recipes-devtools/python/python-werkzeug.inc
@@ -16,15 +16,16 @@ SRC_URI[sha256sum] = "cc64dafbacc716cdd42503cf6c44cb5a35576443d82f29f6829e5c4926
PYPI_PACKAGE = "Werkzeug"
RDEPENDS_${PN} += " \
- python-difflib \
- python-email \
- python-html \
- python-json \
- python-netserver \
- python-numbers \
- python-pkgutil \
- python-subprocess \
- python-threading \
- python-unixadmin \
- python-zlib \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
"
diff --git a/meta-python/recipes-devtools/python/python-werkzeug_0.11.10.bb b/meta-python/recipes-devtools/python/python-werkzeug_0.11.10.bb
index dd1460870b..3892f1357b 100644
--- a/meta-python/recipes-devtools/python/python-werkzeug_0.11.10.bb
+++ b/meta-python/recipes-devtools/python/python-werkzeug_0.11.10.bb
@@ -1,2 +1,4 @@
inherit pypi setuptools
require python-werkzeug.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-zlib"