aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-can.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-can_1.5.2.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-can_1.5.2.bb4
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc
new file mode 100644
index 0000000000..1878f31162
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-can.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Controller Area Network (CAN) interface module for Python"
+SECTION = "devel/python"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=38138baa100d7259934590850bc0406e"
+
+SRC_URI[md5sum] = "f653aecf8b9034bbba32cc04ca6a7b6d"
+SRC_URI[sha256sum] = "edabb426e6cd11c2dc7a98980340135aa0eb02143b0d51bf14e3e6178c131cc3"
+
+PYPI_PACKAGE="python-can"
diff --git a/meta-python/recipes-devtools/python/python-can_1.5.2.bb b/meta-python/recipes-devtools/python/python-can_1.5.2.bb
new file mode 100644
index 0000000000..ec81a9e48d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-can_1.5.2.bb
@@ -0,0 +1,4 @@
+require python-can.inc
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "python-sqlite3"
diff --git a/meta-python/recipes-devtools/python/python3-can_1.5.2.bb b/meta-python/recipes-devtools/python/python3-can_1.5.2.bb
new file mode 100644
index 0000000000..a1d45b88a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-can_1.5.2.bb
@@ -0,0 +1,4 @@
+require python-can.inc
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-sqlite3"