aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-decorator.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-decorator_4.0.10.bb2
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator.inc b/meta-python/recipes-devtools/python/python-decorator.inc
index c1fdfac44b..9264cef439 100644
--- a/meta-python/recipes-devtools/python/python-decorator.inc
+++ b/meta-python/recipes-devtools/python/python-decorator.inc
@@ -13,3 +13,7 @@ SRC_URI[md5sum] = "434b57fdc3230c500716c5aff8896100"
SRC_URI[sha256sum] = "9c6e98edcb33499881b86ede07d9968c81ab7c769e28e9af24075f0a5379f070"
inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-stringold \
+ "
diff --git a/meta-python/recipes-devtools/python/python-decorator_4.0.10.bb b/meta-python/recipes-devtools/python/python-decorator_4.0.10.bb
index f262168467..2a2b455f56 100644
--- a/meta-python/recipes-devtools/python/python-decorator_4.0.10.bb
+++ b/meta-python/recipes-devtools/python/python-decorator_4.0.10.bb
@@ -1,2 +1,4 @@
inherit setuptools
require python-decorator.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-contextlib"