aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-booleanpy.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb2
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-booleanpy.inc b/meta-python/recipes-devtools/python/python-booleanpy.inc
new file mode 100644
index 0000000000..335d7d396d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-booleanpy.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319747a5eb94cddf646037c01ddba47"
+
+SRC_URI[md5sum] = "1189d115a38f84f5df743014926a9159"
+SRC_URI[sha256sum] = "bd19b412435611ecc712603d0fd7d0e280e24698e7a6e3d5f610473870c5dd1e"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb b/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
new file mode 100644
index 0000000000..5f8602d187
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-booleanpy.inc