aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-support/tracker/files/90tracker4
-rw-r--r--meta-gnome/recipes-support/tracker/files/tracker-dbus.service15
-rw-r--r--meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service12
-rw-r--r--meta-gnome/recipes-support/tracker/files/tracker-store.service12
-rw-r--r--meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch13
-rw-r--r--meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch30
-rw-r--r--meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch126
-rw-r--r--meta-gnome/recipes-support/tracker/tracker_0.14.2.bb88
8 files changed, 0 insertions, 300 deletions
diff --git a/meta-gnome/recipes-support/tracker/files/90tracker b/meta-gnome/recipes-support/tracker/files/90tracker
deleted file mode 100644
index 9594b91689..0000000000
--- a/meta-gnome/recipes-support/tracker/files/90tracker
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-/usr/bin/trackerd -m &
-
diff --git a/meta-gnome/recipes-support/tracker/files/tracker-dbus.service b/meta-gnome/recipes-support/tracker/files/tracker-dbus.service
deleted file mode 100644
index c97f49a89d..0000000000
--- a/meta-gnome/recipes-support/tracker/files/tracker-dbus.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=tracker DBus session bus handler
-Before=tracker-store.service
-After=dbus.service
-Requires=dbus.service
-BindTo=tracker-store.service
-
-[Service]
-Type=forking
-EnvironmentFile=-/tmp/tracker.env
-ExecStartPre=@BASE_BINDIR@/rm -rf /tmp/tracker.env
-ExecStart=/bin/sh -c 'echo "DBUS_SESSION_BUS_ADDRESS=`dbus-daemon --fork --session --print-address`" > /tmp/tracker.env'
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service b/meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service
deleted file mode 100644
index 34d9a1e686..0000000000
--- a/meta-gnome/recipes-support/tracker/files/tracker-miner-fs.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=tracker-miner-fs
-After=syslog.target local-fs.target udev.service dbus.service tracker-store.service
-Requires=tracker-store.service
-
-[Service]
-Environment=HOME=/home/root
-EnvironmentFile=-/tmp/tracker.env
-ExecStart=@LIBEXECDIR@/tracker-miner-fs
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-gnome/recipes-support/tracker/files/tracker-store.service b/meta-gnome/recipes-support/tracker/files/tracker-store.service
deleted file mode 100644
index c5037f3ab9..0000000000
--- a/meta-gnome/recipes-support/tracker/files/tracker-store.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=tracker-store
-After=syslog.target local-fs.target dbus.service
-Requires=dbus.service tracker-dbus.service
-BindTo=tracker-dbus.service
-
-[Service]
-EnvironmentFile=-/tmp/tracker.env
-ExecStart=@LIBEXECDIR@/tracker-store
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch b/meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch
deleted file mode 100644
index 5dadda2a29..0000000000
--- a/meta-gnome/recipes-support/tracker/tracker-0.14.2/enable-sqlite-crosscompile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: tracker-0.10.17/m4/sqlite-threadsafe.m4
-===================================================================
---- tracker-0.10.17.orig/m4/sqlite-threadsafe.m4
-+++ tracker-0.10.17/m4/sqlite-threadsafe.m4
-@@ -45,7 +45,7 @@ int main ()
- ]])],
- [ax_cv_sqlite_threadsafe=yes],
- [ax_cv_sqlite_threadsafe=no],
-- [ax_cv_sqlite_threadsafe=no])])
-+ [ax_cv_sqlite_threadsafe=yes])])
-
- LIBS="$save_LIBS"
- ])
diff --git a/meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch b/meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch
deleted file mode 100644
index 6c3d9de107..0000000000
--- a/meta-gnome/recipes-support/tracker/tracker-0.14.2/fix-removable-media-detection.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: tracker-0.14.2/src/libtracker-miner/tracker-storage.c
-===================================================================
---- tracker-0.14.2.orig/src/libtracker-miner/tracker-storage.c 2011-08-03 13:53:16.000000000 +0100
-+++ tracker-0.14.2/src/libtracker-miner/tracker-storage.c 2012-09-10 08:25:18.322215126 +0100
-@@ -20,6 +20,7 @@
- #include "config.h"
-
- #include <string.h>
-+#include <sys/stat.h>
-
- #include <gio/gio.h>
- #include <gio/gunixmounts.h>
-@@ -646,6 +647,17 @@
- gchar *content_type;
- gboolean is_multimedia;
- gboolean is_blank;
-+ struct stat st;
-+
-+ /*
-+ * Consider all files under /media to be
-+ * removable unless the file .this-is-root is
-+ * present.
-+ */
-+ if (!strncmp (mount_path, "/media/",
-+ strlen ("/media/")) &&
-+ stat ("/media/.this-is-root", &st))
-+ is_removable = TRUE;
-
- content_type = mount_guess_content_type (mount, &is_optical, &is_multimedia, &is_blank);
-
diff --git a/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch b/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch
deleted file mode 100644
index fab3371f0f..0000000000
--- a/meta-gnome/recipes-support/tracker/tracker-0.14.2/giflib5-support.patch
+++ /dev/null
@@ -1,126 +0,0 @@
- src/tracker-extract/tracker-extract-gif.c | 36 +++++++++++++++++++++++++++++
- 1 file changed, 36 insertions(+)
---- a/src/tracker-extract/tracker-extract-gif.c
-+++ a/src/tracker-extract/tracker-extract-gif.c
-@@ -75,6 +75,39 @@
- return (GIF_OK);
- }
-
-+#if GIFLIB_MAJOR >= 5
-+static inline void
-+gif_error (const gchar *action, int err)
-+{
-+ const char *str = GifErrorString (err);
-+ if (str != NULL) {
-+ g_message ("%s, error: '%s'", action, str);
-+ } else {
-+ g_message ("%s, undefined error %d", action, err);
-+ }
-+}
-+#else /* GIFLIB_MAJOR >= 5 */
-+static inline void print_gif_error()
-+{
-+#if defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && ((GIFLIB_MAJOR == 4 && GIFLIB_MINOR >= 2) || GIFLIB_MAJOR > 4)
-+ const char *str = GifErrorString ();
-+ if (str != NULL) {
-+ g_message ("GIF, error: '%s'", str);
-+ } else {
-+ g_message ("GIF, undefined error");
-+ }
-+#else
-+ PrintGifError();
-+#endif
-+}
-+#endif /* GIFLIB_MAJOR >= 5 */
-+
-+/* giflib 5.1 changed the API of DGifCloseFile to take two arguments */
-+#if !defined(GIFLIB_MAJOR) || \
-+ !(GIFLIB_MAJOR > 5 || (GIFLIB_MAJOR == 5 && GIFLIB_MINOR >= 1))
-+#define DGifCloseFile(a, b) DGifCloseFile(a)
-+#endif
-+
- static void
- read_metadata (TrackerSparqlBuilder *preupdate,
- TrackerSparqlBuilder *metadata,
-@@ -100,14 +133,22 @@
- ExtBlock extBlock;
-
- if (DGifGetRecordType(gifFile, &RecordType) == GIF_ERROR) {
-- PrintGifError();
-+#if GIFLIB_MAJOR < 5
-+ print_gif_error ();
-+#else /* GIFLIB_MAJOR < 5 */
-+ gif_error ("Could not read next GIF record type", gifFile->Error);
-+#endif /* GIFLIB_MAJOR < 5 */
- return;
- }
-
- switch (RecordType) {
- case IMAGE_DESC_RECORD_TYPE:
- if (DGifGetImageDesc(gifFile) == GIF_ERROR) {
-- PrintGifError();
-+#if GIFLIB_MAJOR < 5
-+ print_gif_error();
-+#else /* GIFLIB_MAJOR < 5 */
-+ gif_error ("Could not get GIF record information", gifFile->Error);
-+#endif /* GIFLIB_MAJOR < 5 */
- return;
- }
-
-@@ -117,7 +158,11 @@
- framedata = g_malloc (framewidth*frameheight);
-
- if (DGifGetLine(gifFile, framedata, framewidth*frameheight)==GIF_ERROR) {
-- PrintGifError();
-+#if GIFLIB_MAJOR < 5
-+ print_gif_error();
-+#else /* GIFLIB_MAJOR < 5 */
-+ gif_error ("Could not load a block of GIF pixes", gifFile->Error);
-+#endif /* GIFLIB_MAJOR < 5 */
- return;
- }
-
-@@ -593,6 +638,9 @@
- gchar *filename, *uri;
- GFile *file;
- int fd;
-+#if GIFLIB_MAJOR >= 5
-+ int err;
-+#endif
-
- preupdate = tracker_extract_info_get_preupdate_builder (info);
- metadata = tracker_extract_info_get_metadata_builder (info);
-@@ -617,8 +665,14 @@
- return FALSE;
- }
-
-+#if GIFLIB_MAJOR < 5
- if ((gifFile = DGifOpenFileHandle (fd)) == NULL) {
-- PrintGifError ();
-+ print_gif_error ();
-+#else /* GIFLIB_MAJOR < 5 */
-+ if ((gifFile = DGifOpenFileHandle (fd, &err)) == NULL) {
-+ gif_error ("Could not open GIF file with handle", err);
-+#endif /* GIFLIB_MAJOR < 5 */
-+ g_free (filename);
- close (fd);
- return FALSE;
- }
-@@ -637,10 +691,15 @@
- g_string_free (where, TRUE);
-
- g_free (uri);
--
-+#if GIFLIB_MAJOR < 5
- if (DGifCloseFile (gifFile) != GIF_OK) {
-- PrintGifError ();
-+ print_gif_error ();
-+ }
-+#else /* GIFLIB_MAJOR < 5 */
-+ if (DGifCloseFile (gifFile, NULL) != GIF_OK) {
-+ gif_error ("Could not close GIF file", gifFile->Error);
- }
-+#endif /* GIFLIB_MAJOR < 5 */
-
- return TRUE;
- }
diff --git a/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb b/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
deleted file mode 100644
index eb36a120fe..0000000000
--- a/meta-gnome/recipes-support/tracker/tracker_0.14.2.bb
+++ /dev/null
@@ -1,88 +0,0 @@
-DESCRIPTION = "Tracker is a tool designed to extract information and metadata about your personal data so that it can be searched easily and quickly."
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ee31012bf90e7b8c108c69f197f3e3a4"
-DEPENDS = "file gstreamer dbus libexif gettext sqlite3 icu gst-plugins-base libgnome-keyring poppler tiff enca libgsf libunistring giflib taglib bzip2 upower gtk+3 libgee networkmanager intltool-native"
-
-RDEPENDS_${PN} += " gvfs gsettings-desktop-schemas"
-
-RDEPENDS_${PN}-nautilus-extension += "nautilus"
-HOMEPAGE = "http://projects.gnome.org/tracker/"
-
-PR = "r7"
-
-inherit autotools pkgconfig gnomebase gettext gsettings systemd gobject-introspection
-
-VER_DIR = "${@gnome_verdir("${PV}")}"
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/tracker/${VER_DIR}/tracker-${PV}.tar.xz \
- file://enable-sqlite-crosscompile.patch \
- file://fix-removable-media-detection.patch \
- file://giflib5-support.patch \
- file://90tracker \
- file://tracker-store.service \
- file://tracker-miner-fs.service \
- file://tracker-dbus.service \
- "
-
-SYSTEMD_SERVICE_${PN} = " tracker-store.service tracker-miner-fs.service tracker-dbus.service "
-SYSTEMD_AUTO_ENABLE = "disable"
-
-EXTRA_OECONF += " tracker_cv_have_ioprio=yes"
-
-PACKAGECONFIG ?= "nautilus"
-PACKAGECONFIG[nautilus] = "--enable-nautilus-extension,--disable-nautilus-extension,nautilus"
-
-# Disable the desktop-centric miners
-EXTRA_OECONF += "--disable-miner-thunderbird --disable-miner-firefox \
- --disable-miner-evolution --disable-miner-flickr"
-
-LEAD_SONAME = "libtrackerclient.so.0"
-
-do_compile_prepend() {
- export GIR_EXTRA_LIBS_PATH="${B}/src/libtracker-sparql-backend/.libs:${B}/src/libtracker-data/.libs:${B}/src/libtracker-common/.libs"
-}
-
-do_install_append() {
- cp -PpR ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true
-# install -d ${D}/${sysconfdir}/X11/Xsession.d/
-# install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/
-
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/tracker-store.service ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/tracker-miner-fs.service ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/tracker-dbus.service ${D}${systemd_unitdir}/system
- sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' \
- -e 's,@BASE_BINDIR@,${base_bindir},g' \
- ${D}${systemd_unitdir}/system/*.service
-}
-
-PACKAGES =+ "${PN}-tests ${PN}-vala ${PN}-nautilus-extension"
-
-FILES_${PN} += "${datadir}/dbus-1/ \
- ${libdir}/tracker-${VER_DIR}/*.so.* \
- ${libdir}/tracker-${VER_DIR}/extract-modules/*.so \
- ${libdir}/tracker-${VER_DIR}/writeback-modules/*.so \
- ${datadir}/icons/hicolor/*/apps/tracker.* \
- ${libdir}/nautilus/extensions-2.0/*.la \
- ${datadir}/glib-2.0/schemas/* \
- ${systemd_unitdir}/system/tracker-store.service \
- ${systemd_unitdir}/system/tracker-miner-fs.service \
- ${systemd_unitdir}/system/tracker-dbus.service \
-"
-
-FILES_${PN}-dev += "${libdir}/tracker-${VER_DIR}/*.la \
- ${libdir}/tracker-${VER_DIR}/*.so \
- ${libdir}/tracker-${VER_DIR}/*/*.la \
- ${libdir}/tracker-${VER_DIR}/extract-modules/*.la"
-
-FILES_${PN}-staticdev += "${libdir}/nautilus/extensions-2.0/*.a"
-FILES_${PN}-dbg += "${libdir}/*/*/.debug \
- ${libdir}/*/.debug"
-FILES_${PN}-tests = "${datadir}/tracker-tests/"
-FILES_${PN}-vala = "${datadir}/vala/"
-FILES_${PN}-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so"
-
-SRC_URI[md5sum] = "f3a871beeebf86fd752863ebd22af9ac"
-SRC_URI[sha256sum] = "9b59330aa2e9e09feee587ded895e9247f71fc25f46b023d616d9969314bc7f1"
-
-# http://errors.yoctoproject.org/Errors/Details/81007/
-PNBLACKLIST[tracker] ?= "BROKEN: fails to build with new binutils-2.27 - the recipe will be removed on 2017-09-01 unless the issue is fixed"