aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch47
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb (renamed from meta-oe/recipes-test/stress-ng/stress-ng_0.09.09.bb)9
2 files changed, 4 insertions, 52 deletions
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch
deleted file mode 100644
index 4b6a9b3916..0000000000
--- a/meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 8537dcafb12be4d986b571f1e1d9f3ceecdc8e63 Mon Sep 17 00:00:00 2001
-From: Tim Orling <timothy.t.orling@linux.intel.com>
-Date: Sun, 7 Jan 2018 21:29:12 -0800
-Subject: [PATCH] stress-fcntl.c: fix syntax errors
-
-Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-
-Upstream-status: Accepted
-(commit 61d93d6857256cd49df6a6302caf6e7bb69b0f46)
----
- stress-fcntl.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/stress-fcntl.c b/stress-fcntl.c
-index 7c15d28..b7eade2 100644
---- a/stress-fcntl.c
-+++ b/stress-fcntl.c
-@@ -173,7 +173,7 @@ static int do_fcntl(const args_t *args, const int fd)
- owner.pid = getpgrp();
- ret = fcntl(fd, F_SETOWN_EX, &owner);
- check_return(args, ret, "F_SETOWN_EX, F_OWNER_PGRP");
--#else if defined(HAVE_GETPGRP) && defined(F_OWNER_GID)
-+#elif defined(HAVE_GETPGRP) && defined(F_OWNER_GID)
- owner.type = F_OWNER_GID;
- owner.pid = getpgrp();
- ret = fcntl(fd, F_SETOWN_EX, &owner);
-@@ -202,7 +202,7 @@ static int do_fcntl(const args_t *args, const int fd)
- owner.type = F_OWNER_PGRP;
- ret = fcntl(fd, F_GETOWN_EX, &owner);
- check_return(args, ret, "F_GETOWN_EX, F_OWNER_PGRP");
--#ele if defined(F_OWNER_GID)
-+#elif defined(F_OWNER_GID)
- owner.type = F_OWNER_GID;
- ret = fcntl(fd, F_GETOWN_EX, &owner);
- check_return(args, ret, "F_GETOWN_EX, F_OWNER_GID");
-@@ -436,7 +436,7 @@ ofd_lock_abort: { /* Nowt */ }
- #endif
- };
-
-- ret = fcntl(fd, F_GET_FILE_RW_HINT, &hint)
-+ ret = fcntl(fd, F_GET_FILE_RW_HINT, &hint);
- if (ret == 0) {
- for (i = 0; i < SIZEOF_ARRAY(hints); i++) {
- hint = hints[i];
---
-2.14.3
-
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.09.bb b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb
index 24f55ada28..7fab43025f 100644
--- a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.09.bb
+++ b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb
@@ -6,14 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "zlib libaio"
SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
+ file://0002-stress-fcntl-fix-build-for-musl.patch \
"
SRC_URI_append_libc-musl = " \
file://0001-Several-changes-to-fix-musl-build.patch \
- file://0002-stress-fcntl-fix-build-for-musl.patch \
- file://0003-stress-fcntl.c-fix-syntax-errors.patch"
-
-SRC_URI[md5sum] = "6e4df71095e780654ccc0a713b8423fe"
-SRC_URI[sha256sum] = "e993fddb1d990a0cdb23b2af6cf6c417a1c09e155ada7c558ad80eae8a5feed3"
+ "
+SRC_URI[md5sum] = "1f8b6c2c2830704d2a2814c16082d48e"
+SRC_URI[sha256sum] = "02cac34a5cb041197af60c1867844c6cbb089a6d10a38cdcf7b8f27bfaa6ef8f"
UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/"
UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar"