aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpointer.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb2
3 files changed, 18 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer.inc b/meta-python/recipes-devtools/python/python-jsonpointer.inc
new file mode 100644
index 0000000000..e678198cc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpointer.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Resolve JSON Pointers in Python"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
+
+inherit pypi
+
+SRC_URI[md5sum] = "190aeb8afcb0efddfe831a4e533e163b"
+SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a4189eac4d"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-re \
+"
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb
index 96b71e3bd8..064bd6c5da 100644
--- a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb
+++ b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb
@@ -1,11 +1,2 @@
-SUMMARY = "Resolve JSON Pointers in Python"
-HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
-
-inherit pypi setuptools
-
-SRC_URI[md5sum] = "190aeb8afcb0efddfe831a4e533e163b"
-SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a4189eac4d"
-
-RDEPENDS_${PN} += "python-re python-json"
+inherit setuptools
+require python-jsonpointer.inc
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb
new file mode 100644
index 0000000000..8d0a09b432
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-jsonpointer.inc