aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb b/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb
index 2b7452b1f2..0e1e460b64 100644
--- a/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb
+++ b/meta-filesystems/recipes-filesystems/yaffs2/yaffs2-utils_git.bb
@@ -1,38 +1,35 @@
SUMMARY = "Yet Another Flash File System"
-
DESCRIPTION = "Tools for managing 'yaffs2' file systems."
SECTION = "base"
HOMEPAGE = "http://www.yaffs.net"
+
LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561"
-PR = "r0"
PV = "0.0+git${SRCPV}"
DEPENDS = "mtd-utils"
-S = "${WORKDIR}/git"
# Source is the HEAD of master branch at the time of writing this recipe
-SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \
- "
+SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master"
SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578"
-
-LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561"
+S = "${WORKDIR}/git"
CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
do_compile() {
- cd utils && oe_runmake
+ cd utils && oe_runmake
}
INSTALL_FILES = "mkyaffsimage \
mkyaffs2image \
"
do_install() {
- install -d ${D}${sbindir}/
- for i in ${INSTALL_FILES}; do
- install -m 0755 utils/$i ${D}${sbindir}/
- done
+ install -d ${D}${sbindir}/
+ for i in ${INSTALL_FILES}; do
+ install -m 0755 utils/$i ${D}${sbindir}/
+ done
}
BBCLASSEXTEND = "native"