aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb37
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.19.bb56
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0201.bb (renamed from meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb)0
3 files changed, 56 insertions, 37 deletions
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
deleted file mode 100644
index 99df6f33ff..0000000000
--- a/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
-DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
-compiler that is compatible with the C compiler that your perl was built \
-with. \
-It can generate the necessary options to the Module::Build constructor or \
-to ExtUtils::MakeMaker's WriteMakefile function."
-SECTION = "libs"
-
-HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
-
-LICENSE = "Artistic-1.0 | GPL-1.0+"
-LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
-
-SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
-SRC_URI[md5sum] = "28be49072585b25df87e54180f741a4d"
-SRC_URI[sha256sum] = "31c47b5b15e3e9fd5ae7b35881a0fffd26a2983b241e7e3a1bc340d6d446186b"
-
-S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
-
-inherit cpan
-
-do_install () {
- cpan_do_install
-}
-
-RDEPENDS_${PN} = " libcapture-tiny-perl \
- perl-module-scalar-util \
- perl-module-io-file \
- perl-module-extutils-makemaker \
- perl-module-file-spec \
- perl-module-exporter \
- perl-module-carp \
- perl-module-file-temp \
- perl-module-lib \
-"
-
-BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.19.bb b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.19.bb
new file mode 100644
index 0000000000..6beb6a9106
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.19.bb
@@ -0,0 +1,56 @@
+SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
+DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
+compiler that is compatible with the C compiler that your perl was built \
+with. \
+It can generate the necessary options to the Module::Build constructor or \
+to ExtUtils::MakeMaker's WriteMakefile function."
+SECTION = "libs"
+
+HOMEPAGE = "https://metacpan.org/release/ExtUtils-CppGuess"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
+SRC_URI[md5sum] = "31e2dca9b7b7c3cc57c3c234290025b1"
+SRC_URI[sha256sum] = "4cc631bab662848ea7c8899e0c62cdfdb367f2fe205b5bd85dfc1082672a6ad3"
+
+S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
+
+inherit cpan ptest-perl
+
+do_install_ptest() {
+ cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/
+ cp -r ${B}/t/module ${D}${PTEST_PATH}/t/
+ cp -r ${B}/blib ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}
+}
+
+RDEPENDS_${PN} += " \
+ libcapture-tiny-perl \
+ perl-module-carp \
+ perl-module-exporter \
+ perl-module-extutils-makemaker \
+ perl-module-extutils-parsexs \
+ perl-module-file-basename \
+ perl-module-file-spec \
+ perl-module-file-spec-functions \
+ perl-module-file-temp \
+ perl-module-io-file \
+ perl-module-lib \
+ perl-module-scalar-util \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-warnings \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ gcc \
+ g++ \
+ libmodule-build-perl \
+ perl-module-blib \
+ perl-module-fatal \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0201.bb
index 6fabf26840..6fabf26840 100644
--- a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
+++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0201.bb