aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_1.20.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_1.20.bb b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
index 17c567095b..b05c8cd35d 100644
--- a/meta-oe/recipes-extended/iotop/iotop_1.20.bb
+++ b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
@@ -12,6 +12,10 @@ inherit pkgconfig
EXTRA_OEMAKE = "V=1 STRIP=true"
+# Workaround BFD linker crash with clang on arm
+# revisit when upgrading binutils and see if its fixed
+LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld"
+
do_install() {
oe_runmake install DESTDIR=${D}
}