aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-connectivity')
-rw-r--r--meta-gnome/recipes-connectivity/folks/folks_0.15.9.bb (renamed from meta-gnome/recipes-connectivity/folks/folks_0.15.5.bb)6
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary/0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch27
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary/0001-meson-Use-PKG_CONFIG_SYSROOT_DIR-when-using-pkg-conf.patch51
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary/0002-Fix-accessibility-issues-with-initializer-of-constan.patch42
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary_44.1.bb (renamed from meta-gnome/recipes-connectivity/geary/geary_40.0.bb)16
-rw-r--r--meta-gnome/recipes-connectivity/gtk-vnc/gtk-vnc_1.3.1.bb30
-rw-r--r--meta-gnome/recipes-connectivity/libnma/libnma_1.10.6.bb (renamed from meta-gnome/recipes-connectivity/libnma/libnma_1.8.38.bb)10
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch30
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb (renamed from meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.26.0.bb)10
9 files changed, 137 insertions, 85 deletions
diff --git a/meta-gnome/recipes-connectivity/folks/folks_0.15.5.bb b/meta-gnome/recipes-connectivity/folks/folks_0.15.9.bb
index 51620bba8e..899b8da261 100644
--- a/meta-gnome/recipes-connectivity/folks/folks_0.15.5.bb
+++ b/meta-gnome/recipes-connectivity/folks/folks_0.15.9.bb
@@ -7,9 +7,9 @@ DEPENDS = " \
libgee \
"
-GNOMEBASEBUILDCLASS = "meson"
-EXTRA_OEMESON += "-Dtests=false"
+EXTRA_OEMESON += "-Dtests=false -Db_lto=false "
+CFLAGS:append:toolchain-clang = " -Wno-error=implicit-function-declaration"
# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
GIR_MESON_OPTION = ""
@@ -25,4 +25,4 @@ PACKAGECONFIG ??= ""
inherit pkgconfig gnomebase gettext gobject-introspection vala features_check
-SRC_URI[archive.sha256sum] = "0fff8a896330cd82aee4598324f7e541c884d0337536212723b4beb38c759086"
+SRC_URI[archive.sha256sum] = "2311b37355c351f33f163fdc394874a22a0a0682c319493d6d8a6e420711415f"
diff --git a/meta-gnome/recipes-connectivity/geary/geary/0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch b/meta-gnome/recipes-connectivity/geary/geary/0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch
deleted file mode 100644
index 22af4f5bea..0000000000
--- a/meta-gnome/recipes-connectivity/geary/geary/0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 166198735e9f4fbe91557df1351b3481bcf79e78 Mon Sep 17 00:00:00 2001
-From: Rico Tzschichholz <ricotz@ubuntu.com>
-Date: Sun, 30 Jan 2022 19:54:11 +0100
-Subject: [PATCH 1/2] Util.Cache.Lru: Workaround missing generic type argument
-
-Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/geary/-/commit/0f75e7a84a39492d0748cec2ba6028e08cae3644]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/client/util/util-cache.vala | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/client/util/util-cache.vala b/src/client/util/util-cache.vala
-index f054e32e..ecc275e8 100644
---- a/src/client/util/util-cache.vala
-+++ b/src/client/util/util-cache.vala
-@@ -12,7 +12,7 @@ public class Util.Cache.Lru<T> : Geary.BaseObject {
- private class CacheEntry<T> {
-
-
-- public static int lru_compare(CacheEntry<T> a, CacheEntry<T> b) {
-+ public static int lru_compare(CacheEntry a, CacheEntry b) {
- if (a.key == b.key) {
- return 0;
- }
---
-2.35.1
-
diff --git a/meta-gnome/recipes-connectivity/geary/geary/0001-meson-Use-PKG_CONFIG_SYSROOT_DIR-when-using-pkg-conf.patch b/meta-gnome/recipes-connectivity/geary/geary/0001-meson-Use-PKG_CONFIG_SYSROOT_DIR-when-using-pkg-conf.patch
new file mode 100644
index 0000000000..1e0640a666
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/geary/geary/0001-meson-Use-PKG_CONFIG_SYSROOT_DIR-when-using-pkg-conf.patch
@@ -0,0 +1,51 @@
+From a300be5877f35379bb569313eec901bda9c8d762 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 30 Apr 2023 22:08:39 -0700
+Subject: [PATCH] meson: Use PKG_CONFIG_SYSROOT_DIR when using pkg-config
+
+OE cross-builds and absolute paths found by pkg-config points to
+non-sysroot'ed locations which are not correct as they point into native
+sysroot from build machine which is incorrect.
+
+Upstream-Status: Inappropriate [OE-specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ meson.build | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index d563dd08..9b72aeb4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -38,6 +38,9 @@ metadata_dir = meson.project_source_root() / 'bindings'/ 'metadata'
+ po_dir = meson.project_source_root() / 'po'
+ vapi_dir = meson.project_source_root() / 'bindings' / 'vapi'
+
++# pkg-config sysroot location
++pkgconf_sysroot = run_command('python3', '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip()
++
+ # Compiler configuration
+ add_project_arguments([
+ # Make sure Meson can find custom VAPIs
+@@ -120,7 +123,7 @@ icu_uc = declare_dependency(
+ if libunwind_dep.found()
+ # We need to add native lib to the search path for these so Flatpak
+ # builds can find it.
+- unwind_lib = libunwind_dep.get_variable(pkgconfig: 'libdir')
++ unwind_lib = pkgconf_sysroot + libunwind_dep.get_variable(pkgconfig: 'libdir')
+ libunwind = declare_dependency(
+ dependencies: [
+ valac.find_library('libunwind', dirs: [vapi_dir, unwind_lib]),
+@@ -207,8 +210,7 @@ vala_unit_proj = subproject(
+ vala_unit_dep = vala_unit_proj.get_variable('vala_unit_dep')
+
+ # Language detection
+-
+-iso_codes_dir = iso_codes.get_variable(pkgconfig: 'prefix')/'share'/'xml'/'iso-codes'
++iso_codes_dir = pkgconf_sysroot + iso_codes.get_variable(pkgconfig: 'prefix')/'share'/'xml'/'iso-codes'
+
+ iso_639_xml = get_option('iso_639_xml')
+ if iso_639_xml == ''
+--
+2.40.1
+
diff --git a/meta-gnome/recipes-connectivity/geary/geary/0002-Fix-accessibility-issues-with-initializer-of-constan.patch b/meta-gnome/recipes-connectivity/geary/geary/0002-Fix-accessibility-issues-with-initializer-of-constan.patch
deleted file mode 100644
index 76315f3a0e..0000000000
--- a/meta-gnome/recipes-connectivity/geary/geary/0002-Fix-accessibility-issues-with-initializer-of-constan.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 64b56e75a54a9fa3f37c7686be97a5c8818413a4 Mon Sep 17 00:00:00 2001
-From: Rico Tzschichholz <ricotz@ubuntu.com>
-Date: Tue, 30 Nov 2021 15:31:31 +0100
-Subject: [PATCH 2/2] Fix accessibility issues with initializer of constants
-
-Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/geary/-/commit/9bd4c82952a0a2c3308c5cc86c0b85650c1fb484]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/client/application/application-client.vala | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/client/application/application-client.vala b/src/client/application/application-client.vala
-index 6ce19ce2..e6ba8533 100644
---- a/src/client/application/application-client.vala
-+++ b/src/client/application/application-client.vala
-@@ -8,16 +8,16 @@
-
- // Defined by CMake build script.
- extern const string GETTEXT_PACKAGE;
--extern const string _APP_ID;
--extern const string _BUILD_ROOT_DIR;
--extern const string _GSETTINGS_DIR;
--extern const string _INSTALL_PREFIX;
--extern const string _NAME_SUFFIX;
-+public extern const string _APP_ID;
-+public extern const string _BUILD_ROOT_DIR;
-+public extern const string _GSETTINGS_DIR;
-+public extern const string _INSTALL_PREFIX;
-+public extern const string _NAME_SUFFIX;
- extern const string _PLUGINS_DIR;
- extern const string _PROFILE;
- extern const string _REVNO;
--extern const string _SOURCE_ROOT_DIR;
--extern const string _VERSION;
-+public extern const string _SOURCE_ROOT_DIR;
-+public extern const string _VERSION;
- extern const string _WEB_EXTENSIONS_DIR;
-
-
---
-2.35.1
-
diff --git a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb b/meta-gnome/recipes-connectivity/geary/geary_44.1.bb
index 4b454dc02d..decae6b2c7 100644
--- a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
+++ b/meta-gnome/recipes-connectivity/geary/geary_44.1.bb
@@ -6,10 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2a2244d5a13871ad950c55877546a6a2"
DEPENDS = " \
appstream-glib \
cairo \
+ desktop-file-utils-native \
enchant2 \
evolution-data-server \
folks \
- gcr \
+ gcr3 \
gmime \
gnome-online-accounts \
gsound \
@@ -25,7 +26,7 @@ DEPENDS = " \
libstemmer \
libxml2 \
sqlite3 \
- webkitgtk \
+ webkitgtk3 \
"
RDEPENDS:${PN} = "gnome-keyring"
@@ -34,15 +35,14 @@ inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala featu
SRC_URI = " \
git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
- file://0001-Util.Cache.Lru-Workaround-missing-generic-type-argum.patch \
- file://0002-Fix-accessibility-issues-with-initializer-of-constan.patch \
+ file://0001-meson-Use-PKG_CONFIG_SYSROOT_DIR-when-using-pkg-conf.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "e561775c1580a9f60a726355b2b897bfc9cb3382"
+SRCREV = "37c378a563d5b1c269d57c34671edc940d1cd180"
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data opengl"
GIR_MESON_OPTION = ""
EXTRA_OEMESON = "-Dprofile=release"
@@ -52,6 +52,10 @@ PACKAGECONFIG[tnef] = "-Dtnef=enabled,-Dtnef=disabled,libytnef"
PACKAGECONFIG[valadoc] = "-Dvaladoc=enabled,-Dvaladoc=disabled"
PACKAGECONFIG ??= ""
+# rfc822/rfc822-message.c:2097:12: error: incompatible pointer to integer conversion returning 'void *' from a function with result type 'gboolean' (aka 'int') [-Wint-conversion]
+#| return NULL;
+#| ^~~~
+CFLAGS:append:toolchain-clang = " -Wno-error=int-conversion"
FILES:${PN} += "${datadir}"
diff --git a/meta-gnome/recipes-connectivity/gtk-vnc/gtk-vnc_1.3.1.bb b/meta-gnome/recipes-connectivity/gtk-vnc/gtk-vnc_1.3.1.bb
new file mode 100644
index 0000000000..8bd37f754c
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/gtk-vnc/gtk-vnc_1.3.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "A VNC client viewer widget for GTK"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4339efb5fd592e45b9e2641de9fe734f"
+
+DEPENDS = " \
+ gdk-pixbuf \
+ glib-2.0 \
+ gnutls \
+ gtk+3 \
+ libgcrypt \
+ libx11 \
+ zlib \
+"
+
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+GIR_MESON_OPTION = ""
+VALA_MESON_OPTION = "with-vala"
+VALA_MESON_ENABLE_FLAG ?= 'enabled'
+VALA_MESON_DISABLE_FLAG ?= 'disabled'
+
+PACKAGECONFIG[pulseaudio] = "-Dpulseaudio=enabled,-Dpulseaudio=disabled,pulseaudio"
+PACKAGECONFIG[sasl] = "-Dsasl=enabled,-Dsasl=disabled,cyrus-sasl"
+
+PACKAGECONFIG ??= "pulseaudio sasl"
+
+inherit pkgconfig gnomebase gettext gobject-introspection vala features_check
+
+PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
+
+SRC_URI[archive.sha256sum] = "512763ac4e0559d0158b6682ca5dd1a3bd633f082f5e4349d7158e6b5f80f1ce"
diff --git a/meta-gnome/recipes-connectivity/libnma/libnma_1.8.38.bb b/meta-gnome/recipes-connectivity/libnma/libnma_1.10.6.bb
index 75c704bc27..9a4dad35d1 100644
--- a/meta-gnome/recipes-connectivity/libnma/libnma_1.8.38.bb
+++ b/meta-gnome/recipes-connectivity/libnma/libnma_1.10.6.bb
@@ -4,13 +4,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "glib-2.0 gtk+3 gtk4 networkmanager"
-GNOMEBASEBUILDCLASS = "meson"
inherit gnomebase gobject-introspection gtk-doc gettext vala features_check
-REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG','gcr','x11','',d)}"
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG','gcr','x11','',d)} opengl"
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
-SRC_URI[archive.sha256sum] = "5ed93eae18456ff5a8a4f408178c1ee198dc8d3a46c65f9075b101916e64e8b4"
+SRC_URI[archive.sha256sum] = "53a6fb2b190ad37c5986caed3e98bede7c3c602399ee4f93c8fc054303d76dab"
PACKAGECONFIG ?= "gcr iso_codes mobile_broadband_provider_info"
PACKAGECONFIG[gcr] = "-Dgcr=true,-Dgcr=false,gcr"
@@ -27,3 +26,8 @@ EXTRA_OEMESON:append:riscv32 = " -Dvapi=false"
EXTRA_OEMESON:append:powerpc64le = " -Dvapi=false"
GTKDOC_MESON_OPTION = "gtk_doc"
+
+do_install:append() {
+ # conflicts with the file provided by network-manager-applet
+ rm -f ${D}${datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
+}
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch
new file mode 100644
index 0000000000..eafd497ae2
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet/0001-linker-scripts-Do-not-export-_IO_stdin_used.patch
@@ -0,0 +1,30 @@
+From e09ba80e342b3b24bb2a46e11dae1c30cc61c75c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 3 Sep 2023 08:48:42 -0700
+Subject: [PATCH] linker-script: Do not export _IO_stdin_used
+
+This is glibc specific toolhain issue, it should have been handled in
+toolchain instead of exposing to applications. This was done to fix
+
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835550
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ linker-script-binary.ver | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/linker-script-binary.ver b/linker-script-binary.ver
+index a2780c0..f030d35 100644
+--- a/linker-script-binary.ver
++++ b/linker-script-binary.ver
+@@ -1,6 +1,5 @@
+ {
+ global:
+- _IO_stdin_used;
+ local:
+ *;
+ };
+--
+2.42.0
+
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.26.0.bb b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb
index 8046b139c0..10e514775a 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.26.0.bb
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb
@@ -4,12 +4,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "gtk+3 libnma libnotify libsecret libgudev networkmanager iso-codes nss"
-GNOMEBASEBUILDCLASS = "meson"
-inherit features_check gnomebase gsettings gtk-icon-cache gettext
+inherit features_check gnomebase gsettings gtk-icon-cache gettext pkgconfig
-REQUIRED_DISTRO_FEATURES = "x11"
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "opengl"
-SRC_URI[archive.sha256sum] = "69611b29064adbd57395fe3e51a9ebde1ea794615f776900453a2bbe3d8cddfd"
+SRC_URI:append:libc-musl = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' file://0001-linker-scripts-Do-not-export-_IO_stdin_used.patch', '', d)}"
+
+SRC_URI[archive.sha256sum] = "a84704487ea3afe1485c47fb2ab598b8f779f540ae0dcbf0a1c5f85e64a7e253"
# We don't not have ubuntu's appindicator (yet?)
EXTRA_OEMESON = "-Dappindicator=no"