aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
index 426076fb21..a5664b0856 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
@@ -28,7 +28,7 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-inherit autotools gtk-doc pkgconfig gettext
+inherit autotools gtk-doc pkgconfig gettext gobject-introspection
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
@@ -42,6 +42,10 @@ do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
+do_compile_prepend() {
+ export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
+}
+
EXTRA_OECONF = "--without-openldap \
--with-libdb=${STAGING_DIR_HOST}${prefix} \
--disable-nntp --disable-goa --disable-weather"