aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
new file mode 100644
index 0000000000..e0c8724a31
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
@@ -0,0 +1,34 @@
+SUMMARY = "A library to access weather information from online services"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+GNOMEBN = "libgweather"
+S = "${WORKDIR}/${GNOMEBN}-${PV}"
+
+inherit gnomebase gsettings gobject-introspection gettext gi-docgen vala features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+SRC_URI += "file://0001-Allow-building-gir-in-cross-environments.patch"
+SRC_URI[archive.sha256sum] = "a6e427b4770ada48945f3aa906af710fc833cff0d42df91f1828302740d794ec"
+
+GTKDOC_MESON_OPTION = "gtk_doc"
+VALA_MESON_OPTION = "enable_vala"
+
+DEPENDS = " \
+ geocode-glib \
+ gtk4 \
+ json-glib \
+ libsoup-3.0 \
+ python3-pygobject-native \
+"
+
+FILES:${PN} += " \
+ ${datadir}/libgweather-4 \
+ ${libdir}/libgweather-4 \
+"
+
+do_configure:prepend() {
+ cp -f ${STAGING_LIBDIR}/girepository-1.0/GLib*typelib ${STAGING_LIBDIR_NATIVE}/girepository-1.0/
+}