aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/libgweather
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/libgweather')
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch21
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb (renamed from meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb)16
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather_40.0.bb24
3 files changed, 18 insertions, 43 deletions
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch b/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch
index 6c6a643edf..3a075de651 100644
--- a/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch
@@ -11,23 +11,16 @@ For us this works perfectly fine
Upstream-Status: Inappropriate [OE-specific]
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- libgweather/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
-diff --git a/libgweather/meson.build b/libgweather/meson.build
-index 08311af..ef554f2 100644
---- a/libgweather/meson.build
-+++ b/libgweather/meson.build
-@@ -208,7 +208,7 @@ lib_libgweather = library('gweather-4',
- )
+--- a/meson.build 2022-09-18 14:48:53.000000000 +0200
++++ b/meson.build 2022-11-26 14:05:13.302487232 +0100
+@@ -51,7 +51,7 @@
+ gen_locations_variant = find_program('build-aux/meson/gen_locations_variant.py')
g_ir_scanner = find_program('g-ir-scanner', required: get_option('introspection'))
-build_gir = get_option('introspection') and g_ir_scanner.found() and not meson.is_cross_build()
+build_gir = get_option('introspection') and g_ir_scanner.found()
+ build_docs = get_option('gtk_doc') and build_gir
- enable_vala = get_option('enable_vala')
- vapigen = find_program('vapigen', required: enable_vala == 'true')
---
-2.34.1
-
+ schemas_srcdir = meson.project_source_root() / 'schemas'
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
index 708d27a61f..e0c8724a31 100644
--- a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
@@ -3,22 +3,24 @@ SUMMARY = "A library to access weather information from online services"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-GNOMEBASEBUILDCLASS = "meson"
GNOMEBN = "libgweather"
S = "${WORKDIR}/${GNOMEBN}-${PV}"
-inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala
+inherit gnomebase gsettings gobject-introspection gettext gi-docgen vala features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI += "file://0001-Allow-building-gir-in-cross-environments.patch"
-SRC_URI[archive.sha256sum] = "440d44801b6f72b48c676e5e37f9109cfee1394fd74cc92725e1b1ba4fae834c"
+SRC_URI[archive.sha256sum] = "a6e427b4770ada48945f3aa906af710fc833cff0d42df91f1828302740d794ec"
GTKDOC_MESON_OPTION = "gtk_doc"
+VALA_MESON_OPTION = "enable_vala"
DEPENDS = " \
geocode-glib \
- gtk+3 \
+ gtk4 \
json-glib \
- libsoup-2.4 \
+ libsoup-3.0 \
python3-pygobject-native \
"
@@ -26,3 +28,7 @@ FILES:${PN} += " \
${datadir}/libgweather-4 \
${libdir}/libgweather-4 \
"
+
+do_configure:prepend() {
+ cp -f ${STAGING_LIBDIR}/girepository-1.0/GLib*typelib ${STAGING_LIBDIR_NATIVE}/girepository-1.0/
+}
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather_40.0.bb b/meta-gnome/recipes-gnome/libgweather/libgweather_40.0.bb
deleted file mode 100644
index 771fc62e1e..0000000000
--- a/meta-gnome/recipes-gnome/libgweather/libgweather_40.0.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "A library to access weather information from online services"
-
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-GNOMEBASEBUILDCLASS = "meson"
-
-inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala features_check upstream-version-is-even
-
-SRC_URI[archive.sha256sum] = "ca4e8f2a4baaa9fc6d75d8856adb57056ef1cd6e55c775ba878ae141b6276ee6"
-
-# gobject-introspection is mandatory and cannot be configured
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
-GIR_MESON_OPTION = ""
-
-GTKDOC_MESON_OPTION = "gtk_doc"
-
-DEPENDS = " \
- geocode-glib \
- gtk+3 \
- json-glib \
- libsoup-2.4 \
- python3-pygobject-native \
-"