aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch30
-rw-r--r--meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb5
2 files changed, 33 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch b/meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch
new file mode 100644
index 0000000000..29d410a0ab
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint/bison3-support.patch
@@ -0,0 +1,30 @@
+Index: libgnomeprint-2.18.8/libgnomeprint/grammar.y
+===================================================================
+--- libgnomeprint-2.18.8.orig/libgnomeprint/grammar.y
++++ libgnomeprint-2.18.8/libgnomeprint/grammar.y
+@@ -99,7 +99,7 @@ gnome_print_filter_parse_prop (GnomePrin
+ }
+
+ static int yylex (void *lvalp);
+-static int yyerror (const char *s);
++static int yyerror (graph_t *g, const char *s);
+ %}
+
+ %union {
+@@ -117,6 +117,7 @@ static int yyerror (const char *s);
+ %type <p> pool
+
+ %pure_parser
++%parse-param { graph_t *graph }
+
+ %start graph
+ %%
+@@ -185,7 +186,7 @@ graph: filter {
+ %%
+
+ static int
+-yyerror (const char *s)
++yyerror (graph_t *g, const char *s)
+ {
+ return -1;
+ }
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb
index 15e513a78d..b17062bebf 100644
--- a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb
+++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb
@@ -1,15 +1,16 @@
LICENSE = "GPLv2"
SECTION = "x11/gnome/libs"
-DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype"
+DEPENDS = "bison-native flex-native libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-inherit pkgconfig gnomebase
+inherit gnomebase
SRC_URI += "file://fix.includes.patch \
file://freetype.patch \
file://0001-configure-use-pkgconfig-for-freetype.patch \
+ file://bison3-support.patch \
"
SRC_URI[archive.md5sum] = "63b05ffb5386e131487c6af30f4c56ac"
SRC_URI[archive.sha256sum] = "1034ec8651051f84d2424e7a1da61c530422cc20ce5b2d9e107e1e46778d9691"