aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gpe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gpe')
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch28
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb22
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch
new file mode 100644
index 0000000000..c976ff4705
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch
@@ -0,0 +1,28 @@
+From c551dece6768f67b74b508e9c0133320205ef2df Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Mon, 23 May 2011 15:03:29 +0200
+Subject: [PATCH] Fix the ordering of LDADD options to fix a compilation failure.
+
+"invalid DSO for symbol `XUngrabServer' definition "
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ src/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2fddc98..45bd850 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -6,7 +6,7 @@ INCLUDES = -DPKGDATADIR=\"$(pkgdatadir)\" \
+ $(GLADE_CFLAGS) \
+ -D_GNU_SOURCE
+
+-LIBS = $(GTK_LIBS) $(GLADE_LIBS) $(XSHAPE_LIBS)
++LIBS = -lX11 $(XSHAPE_LIBS) $(GLADE_LIBS) $(GTK_LIBS)
+
+ bin_PROGRAMS = gpe-scap
+ gpe_scap_SOURCES = scr-i18n.h \
+--
+1.6.6.1
+
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb
new file mode 100644
index 0000000000..cc889c77c1
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A GPE application that allows you to take screenshots."
+SECTION = "gpe"
+PRIORITY = "optional"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
+
+DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup"
+
+PR = "r2"
+
+SRC_URI[md5sum] = "eaf545561b0ad981c9d01833f30fcf95"
+SRC_URI[sha256sum] = "762778421fae7c62d5ec6a9d27986166c0dbbe2ff51fc10bb9b8baff5c367534"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
+SRC_URI += "file://0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch"
+
+RREPLACES_${PN} = "gpe-screenshot"
+