aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
index 656162fb1a..393f04fb31 100644
--- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
@@ -43,22 +43,22 @@ FROM_OE_CORE = "file://arm_crashdump-fix-buffer-align.patch \
SRC_URI += "${BUILD_PATCHES} ${KLIBC_PATCHES} ${WARNING_FIXES} ${FROM_OE_CORE}"
-SRC_URI_append_arm = " file://arm_crashdump.patch"
+SRC_URI:append:arm = " file://arm_crashdump.patch"
-SRC_URI_append_mips = " file://140-mips_disable_devicetree_support.patch"
-SRC_URI_append_mipsel = " file://140-mips_disable_devicetree_support.patch"
+SRC_URI:append:mips = " file://140-mips_disable_devicetree_support.patch"
+SRC_URI:append:mipsel = " file://140-mips_disable_devicetree_support.patch"
-SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch \
+SRC_URI:append:x86 = " file://x86_sys_io.patch file://x86_basename.patch \
file://x86_vfscanf.patch file://x86_kexec_test.patch"
-SRC_URI_append_x86-64 = " file://x86_sys_io.patch file://x86_basename.patch \
+SRC_URI:append:x86-64 = " file://x86_sys_io.patch file://x86_basename.patch \
file://x86_vfscanf.patch file://x86_kexec_test.patch"
-SRC_URI_append_aarch64 = " file://arm64_kexec-image-header.h-add-missing-le64toh.patch \
+SRC_URI:append:aarch64 = " file://arm64_kexec-image-header.h-add-missing-le64toh.patch \
file://arm64-crashdump-arm64.c-fix-warning.patch \
file://arm64_kexec-arm64.c-workaround-for-getrandom-syscall.patch"
-SRC_URI_append_powerpc = " file://powerpc-purgatory-Makefile-remove-unknown-flags.patch"
+SRC_URI:append:powerpc = " file://powerpc-purgatory-Makefile-remove-unknown-flags.patch"
S = "${WORKDIR}/git"
@@ -69,7 +69,7 @@ EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
CFLAGS += "-O2 -I${STAGING_DIR_HOST}${libdir}/klibc/include -I${S}/purgatory/include \
-I${STAGING_DIR_HOST}${libdir}/klibc/include/bits${SITEINFO_BITS}"
-do_compile_prepend() {
+do_compile:prepend() {
# Remove the prepackaged config.h from the source tree as it overrides
# the same file generated by configure and placed in the build tree
rm -f ${S}/include/config.h
@@ -86,9 +86,9 @@ do_compile_prepend() {
PACKAGES =+ "kexec-klibc vmcore-dmesg-klibc"
-FILES_kexec-klibc = "${sbindir}/kexec"
-FILES_vmcore-dmesg-klibc = "${sbindir}/vmcore-dmesg"
+FILES:kexec-klibc = "${sbindir}/kexec"
+FILES:vmcore-dmesg-klibc = "${sbindir}/vmcore-dmesg"
-INSANE_SKIP_${PN} = "arch"
+INSANE_SKIP:${PN} = "arch"
COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|powerpc.*|mips.*)-(linux|freebsd.*)'