aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
new file mode 100644
index 0000000000..03b1562b60
--- /dev/null
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python interface to Bluetooth LE on Linux"
+HOMEPAGE = "https://github.com/IanHarvey/bluepy"
+SECTION = "devel/python"
+
+DEPENDS = "${PYTHON_PN} glib-2.0"
+RDEPENDS_${PN} = "bluez5"
+
+LICENSE = "GPLv2 & PD"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
+
+inherit setuptools3 pkgconfig
+
+SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https;rev=7ad565231a97c304c0eff45f2649cd005e69db09"
+S = "${WORKDIR}/git"
+
+TARGET_CC_ARCH += "${LDFLAGS}"