aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel/netmap/netmap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-kernel/netmap/netmap_git.bb')
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/netmap/netmap_git.bb b/meta-networking/recipes-kernel/netmap/netmap_git.bb
new file mode 100644
index 0000000000..f15a626cba
--- /dev/null
+++ b/meta-networking/recipes-kernel/netmap/netmap_git.bb
@@ -0,0 +1,35 @@
+require netmap.inc
+
+DEPENDS = "netmap-modules"
+
+EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
+ --kernel-sources=${STAGING_KERNEL_DIR} \
+ --no-drivers \
+ --disable-generic \
+ --prefix=${prefix} \
+ --destdir=${D} \
+ --cc='${CC}' \
+ --ld='${LD}' \
+ "
+SRC_URI += "file://0001-testmmap-fix-compile-issue-with-gcc-5.x.patch"
+
+do_fetch[depends] += "netmap-modules:do_fetch"
+
+do_configure () {
+ cd ${S}/LINUX
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ cd ${S}/LINUX
+ make apps
+}
+
+do_install () {
+ cd ${S}/LINUX
+ make install-apps DESTDIR=${D}
+}
+
+FILES_${PN} += "${bindir}"
+RDEPENDS_${PN} = "kernel-module-netmap"
+RRECOMMENDS_${PN} = "kernel-module-netmap"