aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch')
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch b/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
new file mode 100644
index 0000000000..6d5b722eab
--- /dev/null
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
@@ -0,0 +1,19 @@
+The dnsmasq target depends on .configured and $(objs). .configured does an rm
+-f *.o. Yet the only thing telling make to build the .configured target before
+the $(objs) target was the order of the dependencies of the dnsmasq target. We
+can't rely on that order when doing a paralllel make build, so add an explicit
+rule to enforce that order.
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+Upstream-status: Pending
+
+--- dnsmasq-2.68.orig/Makefile
++++ dnsmasq-2.68/Makefile
+@@ -139,6 +139,8 @@ bloatcheck : $(BUILDDIR)/dnsmasq_baselin
+ @rm -f *.o
+ @touch $@
+
++$(objs): .configured
++
+ $(objs:.o=.c) $(hdrs):
+ ln -s $(top)/$(SRC)/$@ .