aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch23
-rw-r--r--meta-networking/recipes-support/ntp/ntp.inc1
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch b/meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch
new file mode 100644
index 0000000000..242276edb0
--- /dev/null
+++ b/meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch
@@ -0,0 +1,23 @@
+set ntp_ok to no if ntp debugging is not enabled.
+
+Upstream-status: Pending
+
+There is a problem in configure.ac file that whether or not
+'--enable-debugging' is specified in configure cmdline, debugging
+is always enabled.
+We should disable ntp debugging by default.
+
+Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com>
+
+---
+--- a/configure.ac
++++ b/configure.ac
+@@ -2458,7 +2458,7 @@
+ [+ include ntpd debugging code]
+ )],
+ [ntp_ok=$enableval],
+- [ntp_ok=yes]
++ [ntp_ok=no]
+ )
+ case "$ntp_ok" in
+ yes)
diff --git a/meta-networking/recipes-support/ntp/ntp.inc b/meta-networking/recipes-support/ntp/ntp.inc
index 49f9901e1e..2c8f48864f 100644
--- a/meta-networking/recipes-support/ntp/ntp.inc
+++ b/meta-networking/recipes-support/ntp/ntp.inc
@@ -23,6 +23,7 @@ SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.g
file://sntp.service \
file://sntp \
file://ntpd.list \
+ file://ntp-disable-debugging.patch \
"
inherit autotools update-rc.d useradd systemd