aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.04.bb6
-rw-r--r--meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb8
-rw-r--r--meta-oe/recipes-benchmark/dbench/dbench_4.0.bb8
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.27.bb6
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb2
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3_492.bb12
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb20
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb8
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_9.2.1.bb6
-rw-r--r--meta-oe/recipes-benchmark/s-suite/s-suite_git.bb6
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb2
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb2
12 files changed, 43 insertions, 43 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.04.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.04.bb
index d7583f0764..91387176b8 100644
--- a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.04.bb
+++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.04.bb
@@ -25,7 +25,7 @@ do_install () {
PACKAGES =+ "bonnie-scripts"
-FILES_${PN} = "${sbindir}"
-FILES_bonnie-scripts = "${bindir}"
+FILES:${PN} = "${sbindir}"
+FILES:bonnie-scripts = "${bindir}"
-RDEPENDS_bonnie-scripts += "perl"
+RDEPENDS:bonnie-scripts += "perl"
diff --git a/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb b/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb
index b21212a430..f8f817e40b 100644
--- a/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb
+++ b/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "A collection of cpuburn programs tuned for different ARM hardware"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://cpuburn-a53.S;beginline=1;endline=22;md5=3b7ccd70144c16d3fe14ac491c2d4a87"
-RPROVIDES_${PN} = "cpuburn-neon"
+RPROVIDES:${PN} = "cpuburn-neon"
PROVIDES += "cpuburn-neon"
SRCREV = "ad7e646700d14b81413297bda02fb7fe96613c3f"
@@ -47,6 +47,6 @@ do_install() {
}
COMPATIBLE_MACHINE ?= "(^$)"
-COMPATIBLE_MACHINE_armv7a = "(.*)"
-COMPATIBLE_MACHINE_armv7ve = "(.*)"
-COMPATIBLE_MACHINE_aarch64 = "(.*)"
+COMPATIBLE_MACHINE:armv7a = "(.*)"
+COMPATIBLE_MACHINE:armv7ve = "(.*)"
+COMPATIBLE_MACHINE:aarch64 = "(.*)"
diff --git a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
index fb6a96e64b..517958b152 100644
--- a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
+++ b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
@@ -1,6 +1,6 @@
SUMMARY = "The dbench (disk) and tbench (TCP) benchmarks"
-SUMMARY_dbench = "Filesystem load benchmark"
-SUMMARY_tbench = "TCP load benchmark"
+SUMMARY:dbench = "Filesystem load benchmark"
+SUMMARY:tbench = "TCP load benchmark"
HOMEPAGE = "http://samba.org/ftp/tridge/dbench/"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
@@ -16,11 +16,11 @@ inherit autotools
PACKAGES =+ "tbench"
-RPROVIDES_${PN}-dbg += "tbench-dbg"
+RPROVIDES:${PN}-dbg += "tbench-dbg"
TARGET_CC_ARCH += "${LDFLAGS}"
-FILES_tbench = "${bindir}/tbench* ${prefix}/share/client.txt"
+FILES:tbench = "${bindir}/tbench* ${prefix}/share/client.txt"
SRC_URI[md5sum] = "1fe56ff71b9a416f8889d7150ac54da4"
SRC_URI[sha256sum] = "6001893f34e68a3cfeb5d424e1f2bfef005df96a22d86f35dc770c5bccf3aa8a"
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.27.bb b/meta-oe/recipes-benchmark/fio/fio_3.27.bb
index d18649db0d..96791948b0 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.27.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.27.bb
@@ -12,12 +12,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libaio zlib coreutils-native"
DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
-RDEPENDS_${PN} = "python3-core bash"
+RDEPENDS:${PN} = "python3-core bash"
PACKAGECONFIG_NUMA = "numa"
# ARM does not currently support NUMA
-PACKAGECONFIG_NUMA_arm = ""
-PACKAGECONFIG_NUMA_armeb = ""
+PACKAGECONFIG_NUMA:arm = ""
+PACKAGECONFIG_NUMA:armeb = ""
PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
PACKAGECONFIG[numa] = ",--disable-numa,numactl"
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index f5e719a35a..5e99e9e4ef 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
DEPENDS = "libpng jpeg udev"
-DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-native wayland-protocols', '', d)}"
+DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-native wayland-protocols', '', d)}"
PV = "2021.02+${SRCPV}"
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb b/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb
index a68a27c970..ba3eaec619 100644
--- a/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb
@@ -23,11 +23,11 @@ S = "${WORKDIR}/${BPN}_${PV}/src/current"
# explicitly listed below. Another, the iozone3 Makefile
# needs to be told about the cross-compiler explicitly here.
#
-EXTRA_OEMAKE_powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
-EXTRA_OEMAKE_powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
-EXTRA_OEMAKE_powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
-EXTRA_OEMAKE_x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'"
-EXTRA_OEMAKE_arm = "linux-arm CC='${CC}' GCC='${CC}'"
+EXTRA_OEMAKE:powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
+EXTRA_OEMAKE:powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
+EXTRA_OEMAKE:powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
+EXTRA_OEMAKE:x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'"
+EXTRA_OEMAKE:arm = "linux-arm CC='${CC}' GCC='${CC}'"
EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'"
TARGET_CC_ARCH += "${LDFLAGS}"
@@ -55,7 +55,7 @@ do_install() {
install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${BPN}/
}
-FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
+FILES:${PN} += "${datadir}/doc/${PN}/copyright.txt"
# LICENSE:
#
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 124b142d83..cfdf420650 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -4,8 +4,8 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "sysfsutils"
-RDEPENDS_${PN} += "bash python3-core"
-RDEPENDS_${PN}-tests += "bash python3-core"
+RDEPENDS:${PN} += "bash python3-core"
+RDEPENDS:${PN}-tests += "bash python3-core"
PV = "2.23"
PE = "1"
@@ -37,9 +37,9 @@ COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
LIBHUGETLBFS_ARCH = "${TARGET_ARCH}"
-LIBHUGETLBFS_ARCH_powerpc = "ppc"
-LIBHUGETLBFS_ARCH_powerpc64 = "ppc64"
-LIBHUGETLBFS_ARCH_powerpc64le = "ppc64le"
+LIBHUGETLBFS_ARCH:powerpc = "ppc"
+LIBHUGETLBFS_ARCH:powerpc64 = "ppc64"
+LIBHUGETLBFS_ARCH:powerpc64le = "ppc64le"
EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} BUILDTYPE=NATIVEONLY V=2"
PARALLEL_MAKE = ""
CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
@@ -65,12 +65,12 @@ do_install() {
PACKAGES =+ "${PN}-tests "
-FILES_${PN} += "${libdir}/*.so"
-FILES_${PN}-dev = "${includedir}"
-FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
-FILES_${PN}-tests += "${libdir}/libhugetlbfs/tests"
+FILES:${PN} += "${libdir}/*.so"
+FILES:${PN}-dev = "${includedir}"
+FILES:${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
+FILES:${PN}-tests += "${libdir}/libhugetlbfs/tests"
-INSANE_SKIP_${PN} = "dev-so"
+INSANE_SKIP:${PN} = "dev-so"
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index e9d1067d43..7d141d8c7e 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -83,7 +83,7 @@ do_install () {
install -m 0644 ${S}/src/webpage-lm.tar ${D}${datadir}/lmbench
}
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
if [ -z "$D" ]; then
if command -v systemd-tmpfiles >/dev/null; then
systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/lmbench.conf
@@ -93,9 +93,9 @@ pkg_postinst_${PN} () {
fi
}
-RDEPENDS_${PN} = "perl"
-FILES_${PN} += "${datadir}/lmbench"
+RDEPENDS:${PN} = "perl"
+FILES:${PN} += "${datadir}/lmbench"
-ALTERNATIVE_${PN} = "stream"
+ALTERNATIVE:${PN} = "stream"
ALTERNATIVE_LINK_NAME[stream] = "${bindir}/stream"
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_9.2.1.bb b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_9.2.1.bb
index 4a8e5b5b2a..c571013a91 100644
--- a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_9.2.1.bb
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_9.2.1.bb
@@ -27,11 +27,11 @@ do_install() {
# continual target reboots if they encounter network problems.
#
SYSTEMD_AUTO_ENABLE = "disable"
-SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
+SYSTEMD_SERVICE:${PN} = "phoromatic-client.service phoromatic-server.service"
-RDEPENDS_${PN} += "bash python3-core php-cli util-linux-lscpu os-release lsb-release"
+RDEPENDS:${PN} += "bash python3-core php-cli util-linux-lscpu os-release lsb-release"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/phoronix-test-suite \
${datadir}/appdata/phoronix-test-suite.appdata.xml \
${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
diff --git a/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb b/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb
index d6852e29fb..a0df05c942 100644
--- a/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb
+++ b/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb
@@ -23,11 +23,11 @@ do_install() {
install -m0755 ${S}/process_config.sh ${D}/opt/S-suite
}
-RDEPENDS_${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat \
+RDEPENDS:${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat \
git"
-FILES_${PN} = "/opt/S-suite/"
+FILES:${PN} = "/opt/S-suite/"
# added to INSANE_SKIP since s-suite have an runtime
# dependency (RDEPENDS) on libaio-dev.
-INSANE_SKIP_${PN} += "dev-deps"
+INSANE_SKIP:${PN} += "dev-deps"
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
index d1725dddd6..46b6788a8f 100644
--- a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
@@ -23,6 +23,6 @@ PACKAGECONFIG[mysql] = "--with-mysql \
--with-mysql-libs=${STAGING_LIBDIR}, \
--without-mysql,mysql5"
-do_configure_prepend() {
+do_configure:prepend() {
touch ${S}/NEWS ${S}/AUTHORS
}
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
index 427ce67d61..c9e2958a6b 100644
--- a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
@@ -21,7 +21,7 @@ do_install() {
oe_runmake install
}
-RDEPENDS_${PN} = "\
+RDEPENDS:${PN} = "\
perl \
perl-module-exporter-heavy \
perl-module-getopt-long \