aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb')
-rw-r--r--meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb b/meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb
index b597ef1ea8..b973c68b01 100644
--- a/meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb
+++ b/meta-oe/recipes-dbs/leveldb/leveldb_1.22.bb
@@ -20,7 +20,7 @@ PACKAGECONFIG[tcmalloc] = ",,gperftools"
EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_SHARED_LIBS=ON -DCMAKE_SKIP_RPATH=ON \
-DLEVELDB_BUILD_TESTS=${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'ON', 'OFF', d)}"
-do_install_append() {
+do_install:append() {
install -D -m 0755 ${B}/leveldbutil ${D}${bindir}/leveldbutil
}
@@ -30,4 +30,4 @@ do_install_ptest() {
# Do not try to build lib32-leveldb for mips64, but allow libn32-leveldb.
#
-COMPATIBLE_HOST_mipsarcho32_pn-lib32-leveldb = "null"
+COMPATIBLE_HOST:mipsarcho32:pn-lib32-leveldb = "null"