aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb')
-rw-r--r--meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb
index 1abfc8819d..fb4be0f166 100644
--- a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb
+++ b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb
@@ -3,9 +3,12 @@ HOMEPAGE = "https://github.com/google/flatbuffers"
SECTION = "console/tools"
LICENSE = "Apache-2.0"
-PACKAGE_BEFORE_PN = "${PN}-compiler"
+inherit python3-dir
+
+PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-${PYTHON_PN}"
RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-${PYTHON_PN} = "${PN}"
RDEPENDS_${PN}-dev += "${PN}-compiler"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
@@ -28,6 +31,13 @@ inherit cmake
S = "${WORKDIR}/git"
+do_install_append() {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ cp -rf ${S}/python/flatbuffers ${D}${PYTHON_SITEPACKAGES_DIR}
+}
+
FILES_${PN}-compiler = "${bindir}"
+FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
+
BBCLASSEXTEND = "native nativesdk"