aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf/protobuf_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf/protobuf_3.4.0.bb')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.4.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.4.0.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.4.0.bb
new file mode 100644
index 0000000000..39108ddd25
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.4.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
+DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \
+efficient yet extensible format. Google uses Protocol Buffers for almost \
+all of its internal RPC protocols and file formats."
+HOMEPAGE = "https://github.com/google/protobuf"
+SECTION = "console/tools"
+LICENSE = "BSD-3-Clause"
+
+PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
+
+DEPENDS = "zlib"
+RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-dev += "${PN}-compiler"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
+
+SRCREV = "80a37e0782d2d702d52234b62dd4b9ec74fd2c95"
+
+PV = "3.4.0+git${SRCPV}"
+
+SRC_URI = "git://github.com/google/protobuf.git;branch=3.4.x"
+
+EXTRA_OECONF += " --with-protoc=echo"
+
+inherit autotools-brokensep
+
+S = "${WORKDIR}/git"
+
+FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
+FILES_${PN}-lite = "${bindir} ${libdir}/libprotobuf-lite${SOLIBS}"
+
+MIPS_INSTRUCTION_SET = "mips"
+
+BBCLASSEXTEND = "native nativesdk"