aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/uftrace
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/uftrace')
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch34
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb (renamed from meta-oe/recipes-devtools/uftrace/uftrace_0.11.bb)8
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 0000000000..4844003517
--- /dev/null
+++ b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,34 @@
+From 8e4e5479cee153db7315d5134663fa87082b39fc Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 25 Mar 2024 17:46:24 -0700
+Subject: [PATCH] include libgen.h for basename
+
+basename prototype has been removed from string.h from latest musl [1]
+compilers e.g. clang-18 flags the absense of prototype as error. therefore
+include libgen.h for providing it.
+
+[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
+
+Upstream-Status: Submitted [https://github.com/namhyung/uftrace/pull/1909]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ utils/utils.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/utils/utils.h b/utils/utils.h
+index 69a6072b..60265431 100644
+--- a/utils/utils.h
++++ b/utils/utils.h
+@@ -11,6 +11,9 @@
+
+ #include <ctype.h>
+ #include <endian.h>
++#ifndef __GLIBC__
++#include <libgen.h>
++#endif
+ #include <limits.h>
+ #include <signal.h>
+ #include <stdbool.h>
+--
+2.44.0
+
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.11.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb
index 6d7696c06e..60436025a3 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.11.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Trace and analyze execution of a program written in C/C++"
+SUMMARY = "Trace and analyze execution of a program written in C/C++, Rust and Python"
HOMEPAGE = "https://github.com/namhyung/uftrace"
BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
SECTION = "devel"
@@ -10,9 +10,9 @@ DEPENDS:append:libc-musl = " argp-standalone"
inherit autotools
-SRCREV = "304a492652dc0fd220f601167c4ebb30e2ae4a39"
+SRCREV = "9d8657e90b918994d7d2bcf6dd2cc7354c35a1b4"
SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https \
- "
+ file://0001-include-libgen.h-for-basename.patch"
S = "${WORKDIR}/git"
LDFLAGS:append:libc-musl = " -largp"
@@ -37,7 +37,7 @@ do_configure() {
FILES_SOLIBSDEV = ""
FILES:${PN} += "${libdir}/*.so"
-COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
+COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm|riscv64)"
# uftrace supports armv6 and above
COMPATIBLE_HOST:armv4 = 'null'