aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/efivar/efivar_0.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/efivar/efivar_0.21.bb')
-rw-r--r--meta-oe/recipes-extended/efivar/efivar_0.21.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar_0.21.bb b/meta-oe/recipes-extended/efivar/efivar_0.21.bb
new file mode 100644
index 0000000000..b5ef90a191
--- /dev/null
+++ b/meta-oe/recipes-extended/efivar/efivar_0.21.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Tools to manipulate UEFI variables"
+DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
+HOMEPAGE = "https://github.com/rhinstaller/efivar"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
+
+DEPENDS_class-target = "popt efivar-native"
+
+SRCREV = "aab6c2a64d90b6e5a63661fb5bd6be8d878b0784"
+SRC_URI = "git://github.com/rhinstaller/efivar.git"
+SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch"
+SRC_URI_append_class-native = " file://efivar-drop-options-not-supported-by-lower-version-gcc.patch"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+do_compile_class-native() {
+ oe_runmake -C src makeguids
+}
+
+do_install_class-native() {
+ install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids
+}
+
+BBCLASSEXTEND = "native"