aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libftdi/libftdi_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libftdi/libftdi_1.3.bb')
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_1.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.3.bb b/meta-oe/recipes-support/libftdi/libftdi_1.3.bb
new file mode 100644
index 0000000000..5eee0dbf3f
--- /dev/null
+++ b/meta-oe/recipes-support/libftdi/libftdi_1.3.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
+FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
+including the popular bitbang mode."
+HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM= "\
+ file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
+ file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
+"
+
+DEPENDS = "libusb1"
+
+SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "156cdf40cece9f8a3ce1582db59a502a"
+SRC_URI[sha256sum] = "9a8c95c94bfbcf36584a0a58a6e2003d9b133213d9202b76aec76302ffaa81f4"
+
+S = "${WORKDIR}/${BPN}1-${PV}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on -DFTDIPP=on,-DFTDI_BUILD_CPP=off -DFTDIPP=off,boost"
+
+inherit cmake binconfig pkgconfig
+
+EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
+
+FILES_${PN}-dev += "${libdir}/cmake"
+
+BBCLASSEXTEND = "native"