aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch')
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch b/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
new file mode 100644
index 0000000000..57c4c46814
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch
@@ -0,0 +1,16 @@
+Index: pidgin-2.6.5/configure.ac
+===================================================================
+--- pidgin-2.6.5.orig/configure.ac
++++ pidgin-2.6.5/configure.ac
+@@ -1470,8 +1470,9 @@ if test "_$pythonpath" != _ ; then
+ AC_CHECK_LIB(pthread, pthread_create, )
+ AC_CHECK_LIB(util, openpty, )
+ AC_CHECK_LIB(db, dbopen, )
+- PY_LIBS="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config -lpython$PY_VERSION"
+- PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
++ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
++ PY_LIBS="-L$PKG_CONFIG_SYSROOT_DIR/usr/lib/python$PY_VERSION/config -lpython$PY_VERSION"
++ PY_CFLAGS="-I$PKG_CONFIG_SYSROOT_DIR/usr/include/python$PY_VERSION"
+ AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
+ AC_MSG_RESULT(ok)
+ else