aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/tree/tree_2.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/tree/tree_2.0.1.bb')
-rw-r--r--meta-oe/recipes-support/tree/tree_2.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tree/tree_2.0.1.bb b/meta-oe/recipes-support/tree/tree_2.0.1.bb
new file mode 100644
index 0000000000..9e1e787f10
--- /dev/null
+++ b/meta-oe/recipes-support/tree/tree_2.0.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A recursive directory listing command"
+HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "http://mama.indstate.edu/users/ice/tree/src/${BP}.tgz"
+SRC_URI[sha256sum] = "e3339c5a194cf6b4080f15ec59faa3679f02d5a793b2147912fbfcfb4cdf2239"
+
+# tree's default CFLAGS for Linux
+CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
+
+do_configure[noexec] = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/${BPN} ${D}${bindir}/
+}