aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/anthy/anthy_9100h.bb25
-rw-r--r--meta-oe/recipes-support/augeas/augeas.inc2
-rw-r--r--meta-oe/recipes-support/ccid/ccid_1.4.24.bb3
-rw-r--r--meta-oe/recipes-support/fbtest/fb-test_git.bb12
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.3.bb4
-rw-r--r--meta-oe/recipes-support/htop/htop_1.0.3.bb2
-rw-r--r--meta-oe/recipes-support/libee/libee.inc10
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb2
-rw-r--r--meta-oe/recipes-support/mysql/mariadb.inc4
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.11.bb56
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb37
-rw-r--r--meta-oe/recipes-support/pam-passwdqc/pam-passwdqc_1.0.5.bb11
-rw-r--r--meta-oe/recipes-support/sharutils/sharutils_4.14.bb6
-rw-r--r--meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb4
-rw-r--r--meta-oe/recipes-support/uim/uim_1.8.6.bb108
-rw-r--r--meta-oe/recipes-support/usb-modeswitch/usb-modeswitch_2.2.0.bb2
16 files changed, 148 insertions, 140 deletions
diff --git a/meta-oe/recipes-support/anthy/anthy_9100h.bb b/meta-oe/recipes-support/anthy/anthy_9100h.bb
index e121b447d3..a65d324eae 100644
--- a/meta-oe/recipes-support/anthy/anthy_9100h.bb
+++ b/meta-oe/recipes-support/anthy/anthy_9100h.bb
@@ -6,9 +6,9 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=11f384074d8e93e263b5664ef08a411a"
SRC_URI = "http://osdn.dl.sourceforge.jp/anthy/37536/anthy-9100h.tar.gz \
- file://not_build_elc.patch \
- file://2ch_t.patch \
- "
+ file://not_build_elc.patch \
+ file://2ch_t.patch \
+"
SRC_URI_append_class-target = "file://target-helpers.patch"
SRC_URI_append_class-native = "file://native-helpers.patch"
@@ -25,18 +25,21 @@ PACKAGES += "${PN}-el libanthy0 libanthy-dev"
FILES_${PN}-dbg += "${libdir}/.debug"
FILES_libanthy0 = "${libdir}/libanthy.so.* \
- ${libdir}/libanthydic.so.* \
- ${libdir}/libanthyinput.so.*"
+ ${libdir}/libanthydic.so.* \
+ ${libdir}/libanthyinput.so.* \
+"
FILES_libanthy-dev = "${libdir}/libanthy*.la \
- ${libdir}/libanthy*.a \
- ${libdir}/libanthy*.so \
- ${includedir}/anthy \
- ${libdir}/pkgconfig/anthy.pc"
+ ${libdir}/libanthy*.a \
+ ${libdir}/libanthy*.so \
+ ${includedir}/anthy \
+ ${libdir}/pkgconfig/anthy.pc \
+"
FILES_${PN}-el = "${datadir}/emacs/*"
FILES_${PN} = "${datadir}/* \
- ${bindir}/* \
- ${sysconfdir}/anthy-conf"
+ ${bindir}/* \
+ ${sysconfdir}/anthy-conf \
+"
BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/augeas/augeas.inc b/meta-oe/recipes-support/augeas/augeas.inc
index 23d12cadfe..354b1809f0 100644
--- a/meta-oe/recipes-support/augeas/augeas.inc
+++ b/meta-oe/recipes-support/augeas/augeas.inc
@@ -26,5 +26,5 @@ RRECOMMENDS_lib${BPN} += "${PN}"
LEAD_SONAME = "libaugeas.so"
do_install_append() {
- rm -fr ${D}${datadir}/vim
+ rm -fr ${D}${datadir}/vim
}
diff --git a/meta-oe/recipes-support/ccid/ccid_1.4.24.bb b/meta-oe/recipes-support/ccid/ccid_1.4.24.bb
index 49f7a0c8b7..31145d0efd 100644
--- a/meta-oe/recipes-support/ccid/ccid_1.4.24.bb
+++ b/meta-oe/recipes-support/ccid/ccid_1.4.24.bb
@@ -7,7 +7,8 @@ DEPENDS = "virtual/libusb0 pcsc-lite"
RDEPENDS_${PN} = "pcsc-lite"
SRC_URI = "https://alioth.debian.org/frs/download.php/file/4171/ccid-${PV}.tar.bz2 \
- file://no-dep-on-libfl.patch "
+ file://no-dep-on-libfl.patch \
+"
SRC_URI[md5sum] = "915a03cda85b60fefbe3654cbdc68ca9"
SRC_URI[sha256sum] = "62cb73c6c009c9799c526f05a05e25f00f0ad86d50f82a714dedcfbf4a7e4176"
diff --git a/meta-oe/recipes-support/fbtest/fb-test_git.bb b/meta-oe/recipes-support/fbtest/fb-test_git.bb
index 13f9e377a8..6a9d4b2787 100644
--- a/meta-oe/recipes-support/fbtest/fb-test_git.bb
+++ b/meta-oe/recipes-support/fbtest/fb-test_git.bb
@@ -11,10 +11,10 @@ SRC_URI = "git://github.com/prpplague/fb-test-app.git"
S = "${WORKDIR}/git"
do_install() {
- install -d ${D}${bindir}
- install -m 0755 fb-test ${D}${bindir}
- # avoid collisions with perf (perf) and mesa-demos (offset)
- for prog in perf rect offset ; do
- install -m 0755 $prog ${D}${bindir}/fb-$prog
- done
+ install -d ${D}${bindir}
+ install -m 0755 fb-test ${D}${bindir}
+ # avoid collisions with perf (perf) and mesa-demos (offset)
+ for prog in perf rect offset ; do
+ install -m 0755 $prog ${D}${bindir}/fb-$prog
+ done
}
diff --git a/meta-oe/recipes-support/gd/gd_2.2.3.bb b/meta-oe/recipes-support/gd/gd_2.2.3.bb
index 80d66c9f7d..c5aff66167 100644
--- a/meta-oe/recipes-support/gd/gd_2.2.3.bb
+++ b/meta-oe/recipes-support/gd/gd_2.2.3.bb
@@ -33,8 +33,8 @@ EXTRA_OECONF += " --disable-rpath \
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
do_install_append() {
- # cleanup buildpaths from gdlib.pc
- sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
+ # cleanup buildpaths from gdlib.pc
+ sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
}
PACKAGES += "${PN}-tools"
diff --git a/meta-oe/recipes-support/htop/htop_1.0.3.bb b/meta-oe/recipes-support/htop/htop_1.0.3.bb
index 4e445c8b35..181661af72 100644
--- a/meta-oe/recipes-support/htop/htop_1.0.3.bb
+++ b/meta-oe/recipes-support/htop/htop_1.0.3.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "055c57927f75847fdc222b5258b079a9542811a9dcf5421c615c7e17f5
LDFLAGS_append_libc-uclibc = " -lubacktrace"
do_configure_prepend () {
- rm -rf ${S}/config.h
+ rm -rf ${S}/config.h
}
inherit autotools
diff --git a/meta-oe/recipes-support/libee/libee.inc b/meta-oe/recipes-support/libee/libee.inc
index 256fa053be..e5a145ab22 100644
--- a/meta-oe/recipes-support/libee/libee.inc
+++ b/meta-oe/recipes-support/libee/libee.inc
@@ -28,12 +28,12 @@ TESTDIR = "tests"
# We presume the tests we are going to install so just build them directly.
#
do_compile_ptest() {
- oe_runmake -C ${TESTDIR} genfile ezapi1
+ oe_runmake -C ${TESTDIR} genfile ezapi1
}
do_install_ptest() {
- install -d ${D}${PTEST_PATH}
- install -m 0755 ${B}/${TESTDIR}/genfile ${D}${PTEST_PATH}
- install -m 0755 ${B}/${TESTDIR}/.libs/ezapi1 ${D}${PTEST_PATH}
- install -m 0755 ${WORKDIR}/ezapi1.sh ${D}${PTEST_PATH}
+ install -d ${D}${PTEST_PATH}
+ install -m 0755 ${B}/${TESTDIR}/genfile ${D}${PTEST_PATH}
+ install -m 0755 ${B}/${TESTDIR}/.libs/ezapi1 ${D}${PTEST_PATH}
+ install -m 0755 ${WORKDIR}/ezapi1.sh ${D}${PTEST_PATH}
}
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
index cf39278a60..9c1a5200b5 100644
--- a/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
+++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
@@ -24,7 +24,7 @@ PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
- '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
+ '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
RDEPENDS_${PN} = "libgcc"
diff --git a/meta-oe/recipes-support/mysql/mariadb.inc b/meta-oe/recipes-support/mysql/mariadb.inc
index 9c3d2340fd..73905b6c06 100644
--- a/meta-oe/recipes-support/mysql/mariadb.inc
+++ b/meta-oe/recipes-support/mysql/mariadb.inc
@@ -139,8 +139,8 @@ do_install() {
${D}${systemd_unitdir}/system/install_db.service
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${sysconfdir}/tmpfiles.d
- echo "f /var/log/mysqld.err 0640 mysql mysql -" \
+ install -d ${D}${sysconfdir}/tmpfiles.d
+ echo "f /var/log/mysqld.err 0640 mysql mysql -" \
> ${D}${sysconfdir}/tmpfiles.d/99-mysqld.conf
fi
install -d ${D}${bindir}
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.11.bb b/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
index 199726fd08..dd159a3b10 100644
--- a/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
@@ -11,12 +11,12 @@ inherit autotools-brokensep ptest
LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
- file://fix-null-pointer.patch \
- file://Fix-the-test-output-format.patch \
- file://Makefile \
- file://run-ptest \
- file://0001-define-run-test-target.patch \
- "
+ file://fix-null-pointer.patch \
+ file://Fix-the-test-output-format.patch \
+ file://Makefile \
+ file://run-ptest \
+ file://0001-define-run-test-target.patch \
+"
SRC_URI[md5sum] = "d3bc88b7ddb9f06d60898f4816ae9127"
SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861"
@@ -24,34 +24,34 @@ SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e
COMPATIBLE_HOST = "^((?!arm).*)$"
do_install() {
- oe_runmake DESTDIR=${D} prefix=${D}/usr install
- #remove the empty man2 directory
- rm -r ${D}${mandir}/man2
+ oe_runmake DESTDIR=${D} prefix=${D}/usr install
+ #remove the empty man2 directory
+ rm -r ${D}${mandir}/man2
}
do_compile_ptest() {
- oe_runmake test
+ oe_runmake test
}
do_install_ptest() {
- #install tests binaries
- local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
- mynode nodemap node-parse pagesize prefered randmap realloc_test \
- tbitmap tshared"
-
- [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
- for i in $test_binaries; do
- install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
- done
-
- local test_scripts="checktopology checkaffinity printcpu regress regress2 \
- shmtest runltp bind_range"
- for i in $test_scripts; do
- install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
- done
-
- install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
- install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
+ #install tests binaries
+ local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
+ mynode nodemap node-parse pagesize prefered randmap realloc_test \
+ tbitmap tshared"
+
+ [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
+ for i in $test_binaries; do
+ install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
+ done
+
+ local test_scripts="checktopology checkaffinity printcpu regress regress2 \
+ shmtest runltp bind_range"
+ for i in $test_scripts; do
+ install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
+ done
+
+ install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
+ install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
}
RDEPENDS_${PN}-ptest = "bash"
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index 8ab9a2b4e0..da1131616b 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -19,11 +19,12 @@ IPP_MD5 = "808b791a6eac9ed78d32a7666804320e"
SRCREV_FORMAT = "opencv"
SRC_URI = "git://github.com/Itseez/opencv.git;name=opencv \
- git://github.com/Itseez/opencv_contrib.git;destsuffix=contrib;name=contrib \
- git://github.com/Itseez/opencv_3rdparty.git;branch=ippicv/master_20151201;destsuffix=party3;name=party3 \
- file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
- file://fixgcc60.patch \
- file://fixpkgconfig.patch"
+ git://github.com/Itseez/opencv_contrib.git;destsuffix=contrib;name=contrib \
+ git://github.com/Itseez/opencv_3rdparty.git;branch=ippicv/master_20151201;destsuffix=party3;name=party3 \
+ file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
+ file://fixgcc60.patch \
+ file://fixpkgconfig.patch \
+"
PV = "3.1+git${SRCPV}"
@@ -35,22 +36,22 @@ do_unpack_extra() {
addtask unpack_extra after do_unpack before do_patch
EXTRA_OECMAKE = "-DPYTHON2_NUMPY_INCLUDE_DIRS:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \
- -DOPENCV_EXTRA_MODULES_PATH=${WORKDIR}/contrib/modules \
- -DWITH_1394=OFF \
- -DCMAKE_SKIP_RPATH=ON \
- -DOPENCV_ICV_PACKAGE_DOWNLOADED=${IPP_MD5} \
- -DOPENCV_ICV_PATH=${WORKDIR}/ippicv_lnx \
- ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \
- ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \
- ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \
- ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
- ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
+ -DOPENCV_EXTRA_MODULES_PATH=${WORKDIR}/contrib/modules \
+ -DWITH_1394=OFF \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DOPENCV_ICV_PACKAGE_DOWNLOADED=${IPP_MD5} \
+ -DOPENCV_ICV_PATH=${WORKDIR}/ippicv_lnx \
+ ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \
+ ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \
+ ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \
+ ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
+ ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
"
EXTRA_OECMAKE_append_x86 = " -DX86=ON"
PACKAGECONFIG ??= "eigen jpeg png tiff v4l libv4l gstreamer samples tbb gphoto2 \
- ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \
- ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libav", "", d)}"
+ ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libav", "", d)}"
PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas,"
PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft,"
@@ -80,7 +81,7 @@ export ANT_DIR="${STAGING_DIR_NATIVE}/usr/share/ant/"
TARGET_CC_ARCH += "-I${S}/include "
PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'oracle-java', '${PN}-java-dbg ${PN}-java', '', d)} \
- ${PN}-samples-dbg ${PN}-samples ${PN}-apps python-opencv"
+ ${PN}-samples-dbg ${PN}-samples ${PN}-apps python-opencv"
python populate_packages_prepend () {
cv_libdir = d.expand('${libdir}')
diff --git a/meta-oe/recipes-support/pam-passwdqc/pam-passwdqc_1.0.5.bb b/meta-oe/recipes-support/pam-passwdqc/pam-passwdqc_1.0.5.bb
index 4e8b7d847b..4233ba430f 100644
--- a/meta-oe/recipes-support/pam-passwdqc/pam-passwdqc_1.0.5.bb
+++ b/meta-oe/recipes-support/pam-passwdqc/pam-passwdqc_1.0.5.bb
@@ -12,9 +12,9 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e284d013ef08e66d4737f446c5890550"
SRC_URI = "http://www.openwall.com/pam/modules/pam_passwdqc/pam_passwdqc-1.0.5.tar.gz \
- file://1000patch-219201.patch \
- file://7000Makefile-fix-CC.patch \
- "
+ file://1000patch-219201.patch \
+ file://7000Makefile-fix-CC.patch \
+"
SRC_URI[md5sum] = "cd9c014f736158b1a60384a8e2bdc28a"
SRC_URI[sha256sum] = "32528ddf7d8219c788b6e7702361611ff16c6340b6dc0f418ff164aadc4a4a88"
@@ -24,10 +24,11 @@ S = "${WORKDIR}/pam_passwdqc-${PV}"
DEPENDS = "libpam"
EXTRA_OEMAKE = "CFLAGS="${CFLAGS} -Wall -fPIC -DHAVE_SHADOW" \
- SECUREDIR=${base_libdir}/security"
+ SECUREDIR=${base_libdir}/security \
+"
do_install() {
- oe_runmake install DESTDIR=${D}
+ oe_runmake install DESTDIR=${D}
}
FILES_${PN} += "${base_libdir}/security/pam_passwdqc.so"
diff --git a/meta-oe/recipes-support/sharutils/sharutils_4.14.bb b/meta-oe/recipes-support/sharutils/sharutils_4.14.bb
index 49981e7f7a..d69e6ecbd4 100644
--- a/meta-oe/recipes-support/sharutils/sharutils_4.14.bb
+++ b/meta-oe/recipes-support/sharutils/sharutils_4.14.bb
@@ -7,12 +7,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
inherit gettext autotools-brokensep
SRC_URI = "ftp://ftp.gnu.org/gnu/sharutils/sharutils-4.14.tar.gz \
- file://fix-for-cross-compiling.patch \
- "
+ file://fix-for-cross-compiling.patch \
+"
SRC_URI[md5sum] = "5686c11131b4c4c0841f8f3ef34d136a"
SRC_URI[sha256sum] = "90f5107c167cfd1b299bb211828d2586471087863dbed698f53109cd5f717208"
do_configure () {
- oe_runconf
+ oe_runconf
}
diff --git a/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb b/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb
index ac8593cb67..4a1b4ce670 100644
--- a/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb
+++ b/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb
@@ -22,9 +22,9 @@ DEPENDS = "linux-libc-headers ncurses"
EXTRA_OEMAKE = "-e USRLIBDIR=${libdir}"
do_compile () {
- oe_runmake 'CC=${CC}'
+ oe_runmake 'CC=${CC}'
}
do_install() {
- oe_runmake install INSTALLDIR=${D}
+ oe_runmake install INSTALLDIR=${D}
}
diff --git a/meta-oe/recipes-support/uim/uim_1.8.6.bb b/meta-oe/recipes-support/uim/uim_1.8.6.bb
index ae193b2008..76a41252d7 100644
--- a/meta-oe/recipes-support/uim/uim_1.8.6.bb
+++ b/meta-oe/recipes-support/uim/uim_1.8.6.bb
@@ -1,15 +1,14 @@
DESCRIPTION = "A multilingual user input method library"
HOMEPAGE = "http://uim.freedesktop.org/"
LICENSE = "BSD-3-Clause & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32463fd29aa303fb2360faeeae17256b"
SECTION = "inputmethods"
-SRC_URI = "http://uim.googlecode.com/files/uim-${PV}.tar.bz2 \
- "
-
-SRC_URI_append_class-target = "file://uim-module-manager.patch \
- file://0001-fix-bug-for-cross-compile.patch"
+SRC_URI = "http://uim.googlecode.com/files/uim-${PV}.tar.bz2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=32463fd29aa303fb2360faeeae17256b"
+SRC_URI_append_class-target = " file://uim-module-manager.patch \
+ file://0001-fix-bug-for-cross-compile.patch \
+"
SRC_URI[md5sum] = "ecea4c597bab1fd4ba98ea84edcece59"
SRC_URI[sha256sum] = "7b1ea803c73f3478917166f04f67cce6e45ad7ea5ab6df99b948c17eb1cb235f"
@@ -24,12 +23,13 @@ LEAD_SONAME = "libuim.so.1"
inherit autotools pkgconfig gettext
EXTRA_OECONF += "--disable-emacs \
- --without-scim \
- --without-m17nlib \
- --without-prime \
- --without-canna \
- --without-mana \
- --without-eb"
+ --without-scim \
+ --without-m17nlib \
+ --without-prime \
+ --without-canna \
+ --without-mana \
+ --without-eb \
+"
CONFIGUREOPTS_remove_class-target = "--disable-silent-rules"
@@ -45,60 +45,62 @@ do_install_append() {
PACKAGES += "uim-xim uim-utils uim-skk uim-gtk2.0 uim-gtk3 uim-fep uim-common uim-anthy libuim0 libuim-dev"
FILES_${PN} = "${bindir}/uim-help \
- ${libdir}/uim/plugin/libuim-* \
- ${libdir}/libuim-scm* \
- ${libdir}/libgcroots* \
- ${libdir}/uim/plugin/libuim-*"
+ ${libdir}/uim/plugin/libuim-* \
+ ${libdir}/libuim-scm* \
+ ${libdir}/libgcroots* \
+ ${libdir}/uim/plugin/libuim-* \
+"
FILES_libuim0 = "${libdir}/uim/plugin/libuim-custom-enabler.* \
- ${libdir}/libuim-custom.so.* \
- ${datadir}/locale/ja/LC_MESSAGES/uim.mo \
- ${datadir}/locale/fr/LC_MESSAGES/uim.mo \
- ${datadir}/locale/ko/LC_MESSAGES/uim.mo \
- ${libdir}/libuim.so.*"
-
+ ${libdir}/libuim-custom.so.* \
+ ${datadir}/locale/ja/LC_MESSAGES/uim.mo \
+ ${datadir}/locale/fr/LC_MESSAGES/uim.mo \
+ ${datadir}/locale/ko/LC_MESSAGES/uim.mo \
+ ${libdir}/libuim.so.* \
+"
FILES_libuim-dev = "${libdir}/libuim*.a \
- ${libdir}/libuim*.la \
- ${libdir}/libuim*.so \
- ${includedir}/uim \
- ${libdir}/pkgconfig/uim.pc"
-
+ ${libdir}/libuim*.la \
+ ${libdir}/libuim*.so \
+ ${includedir}/uim \
+ ${libdir}/pkgconfig/uim.pc \
+"
FILES_uim-anthy = "${libdir}/uim/plugin/libuim-anthy.* \
- ${datadir}/uim/anthy*.scm"
-
+ ${datadir}/uim/anthy*.scm \
+"
FILES_${PN}-dbg += "${libdir}/*/*/*/.debug ${libdir}/*/*/.debug"
FILES_${PN}-dev += "${libdir}/uim/plugin/*.la"
FILES_uim-utils = "${bindir}/uim-sh \
- ${bindir}/uim-module-manager \
- ${libexecdir}/uim-helper-server"
-
+ ${bindir}/uim-module-manager \
+ ${libexecdir}/uim-helper-server \
+"
FILES_uim-xim = "${bindir}/uim-xim \
- ${libexecdir}/uim-candwin-*gtk \
- ${libexecdir}/uim-candwin-*gtk3 \
- ${datadir}/man/man1/uim-xim.1 \
- ${sysconfdir}/X11/xinit/xinput.d/uim*"
-
+ ${libexecdir}/uim-candwin-*gtk \
+ ${libexecdir}/uim-candwin-*gtk3 \
+ ${datadir}/man/man1/uim-xim.1 \
+ ${sysconfdir}/X11/xinit/xinput.d/uim* \
+"
FILES_uim-common = "${datadir}/uim/pixmaps/*.png \
- ${datadir}/uim"
-
+ ${datadir}/uim \
+"
FILES_uim-fep = "${bindir}/uim-fep*"
FILES_uim-gtk2.0 = "${libdir}/gtk-2.0 \
- ${bindir}/uim-toolbar-gtk \
- ${bindir}/uim-toolbar-gtk-systray \
- ${bindir}/uim-*-gtk \
- ${bindir}/uim-input-pad-ja \
- ${libdir}/uim/uim-*-gtk"
-
+ ${bindir}/uim-toolbar-gtk \
+ ${bindir}/uim-toolbar-gtk-systray \
+ ${bindir}/uim-*-gtk \
+ ${bindir}/uim-input-pad-ja \
+ ${libdir}/uim/uim-*-gtk \
+"
FILES_uim-gtk3 = "${libdir}/gtk-3.0 \
- ${bindir}/uim-toolbar-gtk3 \
- ${bindir}/uim-toolbar-gtk3-systray \
- ${bindir}/uim-*-gtk3 \
- ${libdir}/uim/uim-*-gtk3"
-
+ ${bindir}/uim-toolbar-gtk3 \
+ ${bindir}/uim-toolbar-gtk3-systray \
+ ${bindir}/uim-*-gtk3 \
+ ${libdir}/uim/uim-*-gtk3 \
+"
FILES_uim-skk = "${libdir}/uim/plugin/libuim-skk.* \
- ${datadir}/uim/skk*.scm"
+ ${datadir}/uim/skk*.scm \
+"
pkg_postinst_uim-anthy() {
if [ -f /usr/bin/uim-module-manager ]; then
@@ -137,8 +139,8 @@ pkg_postrm_uim-skk() {
pkg_postinst_uim-common() {
if [ -f /usr/bin/uim-module-manager ]; then
/usr/bin/uim-module-manager --path /etc/uim --register \
- tutcode tcode hangul viqr \
- ipa-x-sampa latin byeoru
+ tutcode tcode hangul viqr \
+ ipa-x-sampa latin byeoru
fi
}
diff --git a/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch_2.2.0.bb b/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch_2.2.0.bb
index 52a2f5688c..425f66b91b 100644
--- a/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch_2.2.0.bb
+++ b/meta-oe/recipes-support/usb-modeswitch/usb-modeswitch_2.2.0.bb
@@ -15,5 +15,5 @@ RDEPENDS_${PN} = "tcl"
RRECOMMENDS_${PN} = "usb-modeswitch-data"
do_install() {
- oe_runmake DESTDIR=${D} install
+ oe_runmake DESTDIR=${D} install
}