aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/bats/bats_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/bats/bats_1.5.0.bb')
-rw-r--r--meta-oe/recipes-test/bats/bats_1.5.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/bats/bats_1.5.0.bb b/meta-oe/recipes-test/bats/bats_1.5.0.bb
new file mode 100644
index 0000000000..ffbb37c8a1
--- /dev/null
+++ b/meta-oe/recipes-test/bats/bats_1.5.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Bash Automated Testing System"
+DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
+provides a simple way to verify that the UNIX programs you write behave as expected."
+AUTHOR = "Sam Stephenson & bats-core organization"
+HOMEPAGE = "https://github.com/bats-core/bats-core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
+
+SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https"
+# v1.4.1
+SRCREV = "99d64eb017abcd6a766dd0d354e625526da69cb3"
+
+S = "${WORKDIR}/git"
+
+do_configure:prepend() {
+ sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats
+ sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file
+ sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test
+}
+
+do_install() {
+ # Just a bunch of bash scripts to install
+ ${S}/install.sh ${D}${prefix} ${baselib}
+}
+
+RDEPENDS:${PN} = "bash"
+FILES:${PN} += "${libdir}/bats-core/*"
+
+PACKAGECONFIG ??= "pretty"
+PACKAGECONFIG[pretty] = ",,,ncurses"