aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 6ca652e12d..8850f8eb9a 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -106,6 +106,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-dominate \
python3-dynamic-dispatch \
python3-ecdsa \
+ python3-editables \
python3-editor \
python3-email-validator \
python3-engineio \
@@ -136,7 +137,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-flask-nav \
python3-flask-pymongo \
python3-flask-restful \
- python3-flask-script \
python3-flask-sijax \
python3-flask-socketio \
python3-flask-sqlalchemy \
@@ -156,6 +156,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-gmqtt \
python3-gnupg \
python3-google-api-python-client \
+ python3-gpiod \
python3-gpsd-py3 \
python3-graphviz \
python3-greenlet \
@@ -167,6 +168,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-h11 \
python3-h2 \
python3-h5py \
+ python3-hatchling \
python3-haversine \
python3-hpack \
python3-html2text \
@@ -208,7 +210,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-jsonpath-rw \
python3-jsonpointer \
python3-jsonref \
- python3-jsonrpcserver \
python3-jsonschema \
python3-jstyleson \
python3-kconfiglib \
@@ -269,6 +270,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-parso \
python3-passlib \
python3-pastedeploy \
+ python3-pathspec \
python3-pathtools3 \
python3-pep8 \
python3-periphery \
@@ -310,7 +312,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-pyconnman \
python3-pycurl \
python3-pydbus \
- python3-pydbus-manager \
python3-pydicti \
python3-pyephem \
python3-pyexpect \
@@ -319,7 +320,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-pyflakes \
python3-pyhamcrest \
python3-pyiface \
- python3-pyinotify \
python3-pyjks \
python3-pyjwt \
python3-pykickstart \
@@ -349,7 +349,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-pytest-forked \
python3-pytest-helpers-namespace \
python3-pytest-html \
- python3-pytest-lazy-fixture \
+ python3-pytest-lazy-fixtures \
python3-pytest-metadata \
python3-pytest-tempdir \
python3-pytest-timeout \
@@ -358,7 +358,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-python-vlc \
python3-pytoml \
python3-pytun \
- python3-pytz-deprecation-shim \
python3-pyudev \
python3-pyusb \
python3-pywbem \
@@ -389,6 +388,8 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-send2trash \
python3-sentry-sdk \
python3-serpent \
+ python3-service-identity \
+ python3-setuptools-declarative-requirements \
python3-sh \
python3-sijax \
python3-simpleeval \
@@ -408,7 +409,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-sqlparse \
python3-sqlsoup \
python3-stevedore \
- python3-strict-rfc3339 \
python3-supervisor \
python3-sympy \
python3-tabulate \
@@ -425,6 +425,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-trafaret-config \
python3-traitlets \
python3-transitions \
+ python3-trustme \
python3-twine \
python3-twisted \
python3-twitter \
@@ -432,7 +433,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-txaio \
python3-txdbus \
python3-txws \
- python3-typed-ast \
python3-typeguard \
python3-tzlocal \
python3-u-msgpack-python \
@@ -440,15 +440,16 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-unidiff \
python3-uritemplate \
python3-vcversioner \
+ python3-versioneer \
python3-versiontools \
python3-visitor \
python3-waitress \
python3-watchdog \
+ python3-watchdogdev \
python3-web3 \
python3-webcolors \
python3-webencodings \
python3-websocket-client \
- python3-websockets \
python3-werkzeug \
python3-werkzeug \
python3-whoosh \
@@ -456,7 +457,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-wtforms \
python3-xlrd \
python3-xlsxwriter \
- python3-xmlrunner \
python3-xmltodict \
python3-xmodem \
python3-xstatic \
@@ -507,8 +507,8 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\
python3-pyasn1-modules-ptest \
python3-pyroute2-ptest \
python3-pyserial-ptest \
- python3-pytest-lazy-fixture-ptest \
python3-pytoml-ptest \
+ python3-pyzmq-ptest \
python3-requests-file-ptest \
python3-requests-toolbelt-ptest \
python3-scrypt-ptest \