aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-crc32c_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-crc32c_2.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-crc32c_2.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-crc32c_2.3.bb b/meta-python/recipes-devtools/python/python3-crc32c_2.3.bb
new file mode 100644
index 0000000000..da756ea074
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-crc32c_2.3.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A python package implementing the crc32c algorithmin hardware and software"
+HOMEPAGE = "https://github.com/ICRAR/crc32c"
+
+LICENSE = "BSD-2-Clause & BSD-3-Clause & CRC32C-ADLER & LGPL-2.0-or-later"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE.google-crc32c;md5=e9ed01b5e5ac9eae23fc2bb33701220c \
+ file://LICENSE.slice-by-8;md5=6b3bc7709d6b2db6646ec2467310ff6b \
+ file://crc32c_adler.c;beginline=9;endline=24;md5=9c8bd2afd2d340fd37c038759cd4eff8 \
+"
+
+SRC_URI[sha256sum] = "17ce6c596ad0d53df52dcd72defb66984aeabd98fbefea7ba848a6b6bdece36a"
+
+inherit pypi setuptools3
+
+do_compile:prepend() {
+ if ! grep 'platform =' setup.cfg; then
+ printf "[build_ext]\nplatform = ${TARGET_ARCH}" >> setup.cfg
+ fi
+}
+
+RDEPENDS:${PN} += "python3-core"