aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
index ec16e8884e..a7b156535d 100644
--- a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
@@ -6,13 +6,22 @@ HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+DEPENDS += "python3-pip-native"
+
+SRC_URI += "file://run-ptest \
+ "
SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
-DEPENDS += "python3-pip-native"
+inherit ptest pypi setuptools3
-inherit pypi setuptools3
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
+}
-PACKAGECONFIG[testing] = ",,,python3-pre-commit"
+RDEPENDS_${PN}-ptest += "\
+ python3-pytest \
+"
RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"