aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch34
1 files changed, 20 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 4713da174f..07276c17f6 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -26,28 +26,34 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
setup.py | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
+diff --git a/setup.py b/setup.py
+index cc53e79..be3bc78 100644
--- a/setup.py
+++ b/setup.py
-@@ -87,8 +87,11 @@ def check_linker_need_libatomic():
- """Test if linker on system needs libatomic."""
- code_test = (b'#include <atomic>\n' +
- b'int main() { return std::atomic<int64_t>{}; }')
-- cxx = os.environ.get('CXX', 'c++')
-- cpp_test = subprocess.Popen([cxx, '-x', 'c++', '-std=c++11', '-'],
+@@ -88,9 +88,11 @@
+ b"#include <atomic>\n"
+ + b"int main() { return std::atomic<int64_t>{}; }"
+ )
+- cxx = os.environ.get("CXX", "c++")
+- cpp_test = subprocess.Popen(
+- [cxx, "-x", "c++", "-std=c++14", "-"],
+ cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++'
+ if not cxx_args:
+ cxx_args = "-g"
+
-+ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++11', '-'],
- stdin=PIPE,
- stdout=PIPE,
- stderr=PIPE)
-@@ -98,7 +101,7 @@ def check_linker_need_libatomic():
++ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++14', '-'],
+ stdin=PIPE,
+ stdout=PIPE,
+ stderr=PIPE,
+@@ -101,7 +103,7 @@
# Double-check to see if -latomic actually can solve the problem.
# https://github.com/grpc/grpc/issues/22491
cpp_test = subprocess.Popen(
-- [cxx, '-x', 'c++', '-std=c++11', '-', '-latomic'],
-+ [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-', '-latomic'],
+- [cxx, "-x", "c++", "-std=c++14", "-", "-latomic"],
++ [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'],
stdin=PIPE,
stdout=PIPE,
- stderr=PIPE)
+ stderr=PIPE,
+--
+2.25.1
+