aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
index 3af033d966..cbc8ce95fc 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
@@ -7,14 +7,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
DEPENDS += "${PYTHON_PN}-protobuf"
SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
-SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
+SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \
file://boring_ssl.patch \
file://mips_bigendian.patch \
file://0001-absl-always-use-asm-sgidefs.h.patch \
"
SRC_URI[sha256sum] = "1f79d8a24261e3c12ec3a6c25945ff799ae09874fd24815bc17c2dc37715ef6c"
-RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
+RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-six \
"
@@ -24,17 +24,17 @@ inherit pypi
export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
-BORING_SSL_PLATFORM_arm = "linux-arm"
-BORING_SSL_PLATFORM_x86-64 = "linux-x86_64"
+BORING_SSL_PLATFORM:arm = "linux-arm"
+BORING_SSL_PLATFORM:x86-64 = "linux-x86_64"
BORING_SSL_PLATFORM ?= "unsupported"
export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}"
-BORING_SSL_x86-64 = "1"
-BORING_SSL_arm = "1"
+BORING_SSL:x86-64 = "1"
+BORING_SSL:arm = "1"
BORING_SSL ?= "0"
export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}"
-GRPC_CFLAGS_append_toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions"
+GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions"
export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}"
CLEANBROKEN = "1"
@@ -44,4 +44,4 @@ BBCLASSEXTEND = "native nativesdk"
CCACHE_DISABLE = "1"
# needs vdso support
-COMPATIBLE_HOST_libc-musl_powerpc64le = "null"
+COMPATIBLE_HOST:libc-musl:powerpc64le = "null"