aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb b/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
new file mode 100644
index 0000000000..b8a6db2b11
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "IPython: Productive Interactive Computing"
+HOMEPAGE = "https://ipython.org"
+AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
+
+PYPI_PACKAGE = "ipython"
+
+SRC_URI[sha256sum] = "54bbd1fe3882457aaf28ae060a5ccdef97f212a741754e420028d4ec5c2291dc"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-jedi \
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-pickleshare \
+ ${PYTHON_PN}-traitlets \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-pygments \
+ ${PYTHON_PN}-backcall \
+ ${PYTHON_PN}-pydoc \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-pexpect \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-sqlite3 \
+"
+
+inherit setuptools3 pypi