aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb
new file mode 100644
index 0000000000..7d464b16c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Library to process JSON-RPC requests"
+HOMEPAGE = "https://github.com/bcb/jsonrpcserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c89120516900f96f4c60d35fdc4c3f15"
+
+SRC_URI[md5sum] = "c1cc652bdeb04b8ce3ad962fbab34daf"
+SRC_URI[sha256sum] = "3a35c0ef21174ca98f995f99688cebadda97053785833fbb31ec862d6b157f6d"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-apply-defaults \
+ python3-asyncio \
+ python3-core \
+ python3-json \
+ python3-jsonschema \
+ python3-logging \
+ python3-netclient \
+ python3-pkgutil \
+ python3-typing \
+"
+
+BBCLASSEXTEND = "native nativesdk"