aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.3.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.3.bb
new file mode 100644
index 0000000000..c2500300f1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.3.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Library to process JSON-RPC requests"
+HOMEPAGE = "https://github.com/bcb/jsonrpcserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=61b63ea9d36f6fb63ddaaaac8265304f"
+
+SRC_URI[sha256sum] = "0cc514559596fa380bf188e31b0cdf3d9e6d9cc162fdca8a49ed511b291a9ae1"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ python3-apply-defaults \
+ python3-asyncio \
+ python3-core \
+ python3-json \
+ python3-jsonschema \
+ python3-logging \
+ python3-netclient \
+ python3-pkgutil \
+"
+
+BBCLASSEXTEND = "native nativesdk"