aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb
new file mode 100644
index 0000000000..433bfd60e8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.9.2.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Seamless operability between C++11 and Python"
+HOMEPAGE = "https://github.com/wjakob/pybind11"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
+
+DEPENDS = "boost"
+
+SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
+ file://0001-Do-not-strip-binaries.patch \
+ file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
+"
+SRCREV = "914c06fb252b6cc3727d0eedab6736e88a3fcb01"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
+
+inherit cmake setuptools3 python3native
+
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+PIP_INSTALL_PACKAGE = "pybind11"
+
+do_configure() {
+ cmake_do_configure
+}
+
+do_compile() {
+ setuptools3_do_compile
+ cmake_do_compile
+}
+
+do_install() {
+ setuptools3_do_install
+ cmake_do_install
+}
+
+BBCLASSEXTEND = "native nativesdk"