aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb
new file mode 100644
index 0000000000..c3e53b5183
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "The new Python SDK for Sentry.io"
+DESCRIPTION = "This is the next line of the Python SDK \
+for Sentry, intended to replace the raven package on PyPI."
+HOMEPAGE = "https://github.com/getsentry/sentry-python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=03dc788d9a9486be5e6a1d99c2c1ce3a"
+
+RDEPENDS:${PN} += "\
+ python3-urllib3 \
+ python3-core \
+ python3-json \
+ python3-logging \
+ python3-threading \
+ python3-compression \
+ python3-datetime \
+"
+
+SRC_URI[sha256sum] = "509aa9678c0512344ca886281766c2e538682f8acfa50fd8d405f8c417ad0625"
+
+PYPI_PACKAGE = "sentry-sdk"
+
+inherit pypi setuptools3