aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-smpplib_2.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-smpplib_2.2.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-smpplib_2.2.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-smpplib_2.2.3.bb b/meta-python/recipes-devtools/python/python3-smpplib_2.2.3.bb
new file mode 100644
index 0000000000..7979f04c5b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-smpplib_2.2.3.bb
@@ -0,0 +1,31 @@
+SUMMARY = "SMPP library for python"
+SECTION = "devel/python"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://README.md;md5=8b4e2ac8cf248f7b991784f88b630852"
+
+PYPI_PACKAGE = "smpplib"
+SRC_URI[sha256sum] = "5215a95b0538d26f189600e0982b31da8281f7453cd6e2862c5b21e3e1002331"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN} += " \
+ python3-logging \
+ python3-six \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-mock \
+ python3-profile \
+ python3-pytest \
+ python3-unittest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/smpplib/tests/* ${D}${PTEST_PATH}/tests/
+}