aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-isort.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-isort_4.2.15.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_4.2.15.bb2
3 files changed, 14 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-isort.inc b/meta-python/recipes-devtools/python/python-isort.inc
new file mode 100644
index 0000000000..9884c44f18
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-isort.inc
@@ -0,0 +1,10 @@
+SUMMARY = "A Python utility / library to sort Python imports."
+HOMEPAGE = "https://pypi.python.org/pypi/isort"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "34915a2ce60e6fe3dbcbf5982deef9b4"
+SRC_URI[sha256sum] = "79f46172d3a4e2e53e7016e663cc7a8b538bec525c36675fcfd2767df30b3983"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-isort_4.2.15.bb b/meta-python/recipes-devtools/python/python-isort_4.2.15.bb
index b310fda020..fa46d89b5e 100644
--- a/meta-python/recipes-devtools/python/python-isort_4.2.15.bb
+++ b/meta-python/recipes-devtools/python/python-isort_4.2.15.bb
@@ -1,11 +1,2 @@
-SUMMARY = "A Python utility / library to sort Python imports."
-HOMEPAGE = "https://pypi.python.org/pypi/isort"
-LICENSE = "MIT"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
-
-SRC_URI[md5sum] = "34915a2ce60e6fe3dbcbf5982deef9b4"
-SRC_URI[sha256sum] = "79f46172d3a4e2e53e7016e663cc7a8b538bec525c36675fcfd2767df30b3983"
-
-inherit setuptools pypi
-
+inherit setuptools
+require python-isort.inc
diff --git a/meta-python/recipes-devtools/python/python3-isort_4.2.15.bb b/meta-python/recipes-devtools/python/python3-isort_4.2.15.bb
new file mode 100644
index 0000000000..755b3e2f23
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-isort_4.2.15.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-isort.inc