aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch26
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone/80oe.conf.in (renamed from meta-python/recipes-connectivity/gateone/gateone/80oe.conf)5
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone/gateone-init.in (renamed from meta-python/recipes-connectivity/gateone/gateone/gateone-init)8
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone/gateone.service10
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone/gateone.service.in10
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone_git.bb22
6 files changed, 31 insertions, 50 deletions
diff --git a/meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch b/meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch
deleted file mode 100644
index 5f5fa9117e..0000000000
--- a/meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From d811d3bdf06d78c93c48bef762c19c392c879077 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Tue, 26 Nov 2013 15:54:10 +0100
-Subject: [PATCH] configuration.py: Hack around broken gethostname thingy
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
- gateone/core/configuration.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gateone/core/configuration.py b/gateone/core/configuration.py
-index da41cbd..d1c8222 100644
---- a/gateone/core/configuration.py
-+++ b/gateone/core/configuration.py
-@@ -162,7 +162,7 @@ def define_options(installed=True):
- ]
- # Used both http and https above to demonstrate that both are acceptable
- try:
-- additional_origins = socket.gethostbyname_ex(socket.gethostname())
-+ additional_origins = [] # additional_origins = socket.gethostbyname_ex(socket.gethostname())
- except socket.gaierror:
- # Couldn't get any IPs from the hostname
- additional_origins = []
---
-1.8.4.2
-
diff --git a/meta-python/recipes-connectivity/gateone/gateone/80oe.conf b/meta-python/recipes-connectivity/gateone/gateone/80oe.conf.in
index cde98bc10d..4503da4221 100644
--- a/meta-python/recipes-connectivity/gateone/gateone/80oe.conf
+++ b/meta-python/recipes-connectivity/gateone/gateone/80oe.conf.in
@@ -2,13 +2,14 @@
{
"*": {
"gateone": { // These settings apply to all of Gate One
+ "log_file_prefix": "@localstate@/log/gateone.log", // default would be /var/log/gateone/gateone.log
"log_file_max_size": 5242880, // 5 megabyte logs for OE by default (default would normally be 100Mb)
"log_file_num_backups": 2, // Default is normally 10
"origins": ["*"], // Every device has a unique origin
"logging": "info",
- "pid_file": "/var/run/gateone.pid",
+ "pid_file": "/run/gateone.pid",
"session_dir": "/tmp/gateone",
- "user_dir": "/var/lib/gateone/users"
+ "user_dir": "@localstate@/lib/gateone/users"
},
"terminal": {
// Disabling session logging for embedded devices is a good idea (limited/slow storage)
diff --git a/meta-python/recipes-connectivity/gateone/gateone/gateone-init b/meta-python/recipes-connectivity/gateone/gateone/gateone-init.in
index a1cf5ce7e9..86d655c94d 100644
--- a/meta-python/recipes-connectivity/gateone/gateone/gateone-init
+++ b/meta-python/recipes-connectivity/gateone/gateone/gateone-init.in
@@ -11,13 +11,13 @@
. /etc/init.d/functions
NAME=gateone
-DAEMON=/var/lib/gateone/gateone.py
-PIDFILE=/var/run/gateone.pid
-WORKDIR=/var/lib/gateone
+DAEMON=@bindir@/gateone
+PIDFILE=/run/gateone.pid
+WORKDIR=@localstate@/lib/gateone
do_start() {
cd $WORKDIR
- /usr/bin/python $DAEMON > /dev/null 2>&1 &
+ @bindir@/python $DAEMON > /dev/null 2>&1 &
cd $OLDPWD
}
diff --git a/meta-python/recipes-connectivity/gateone/gateone/gateone.service b/meta-python/recipes-connectivity/gateone/gateone/gateone.service
deleted file mode 100644
index 7b14d3e6de..0000000000
--- a/meta-python/recipes-connectivity/gateone/gateone/gateone.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=GateOne daemon
-ConditionPathExists=|/var/lib/gateone
-
-[Service]
-WorkingDirectory=/var/lib/gateone
-ExecStart=/usr/bin/python /usr/bin/gateone
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-python/recipes-connectivity/gateone/gateone/gateone.service.in b/meta-python/recipes-connectivity/gateone/gateone/gateone.service.in
new file mode 100644
index 0000000000..44667275a2
--- /dev/null
+++ b/meta-python/recipes-connectivity/gateone/gateone/gateone.service.in
@@ -0,0 +1,10 @@
+[Unit]
+Description=GateOne daemon
+ConditionPathExists=|@localstate@/lib/gateone
+
+[Service]
+WorkingDirectory=@localstate@/lib/gateone
+ExecStart=@bindir@/python @bindir@/gateone
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-python/recipes-connectivity/gateone/gateone_git.bb
index 7eae12a8bf..5ff753eda6 100644
--- a/meta-python/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-python/recipes-connectivity/gateone/gateone_git.bb
@@ -3,14 +3,13 @@ LICENSE = "AGPL-3.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
-PV = "1.2"
-SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6"
-SRC_URI = "git://github.com/liftoff/GateOne.git \
- file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \
+PV = "1.2+git${SRCPV}"
+SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
+SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
file://gateone-avahi.service \
- file://80oe.conf \
- file://gateone.service \
- file://gateone-init \
+ file://80oe.conf.in \
+ file://gateone.service.in \
+ file://gateone-init.in \
"
S = "${WORKDIR}/git"
@@ -28,7 +27,12 @@ DISTUTILS_INSTALL_ARGS = "--root=${D} \
do_install_append() {
# fix up hardcoded paths
- sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service
+ for file in gateone.service gateone-init 80oe.conf; do
+ sed -e s:@bindir@:${bindir}:g \
+ -e s:@localstate@:${localstatedir}:g \
+ < ${WORKDIR}/$file.in \
+ > ${WORKDIR}/$file
+ done
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
@@ -49,6 +53,7 @@ FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYT
RDEPENDS_${PN} = "mime-support \
openssh-ssh \
python-compression \
+ python-contextlib \
python-crypt \
python-datetime \
python-email \
@@ -76,6 +81,7 @@ RDEPENDS_${PN} = "mime-support \
python-tornado \
python-unixadmin \
python-xml \
+ python-html5lib \
bash \
"