aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cycler.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-cycler_0.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb2
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cycler.inc b/meta-python/recipes-devtools/python/python-cycler.inc
new file mode 100644
index 0000000000..e1fd7f7b8c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cycler.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Composable style cycles"
+HOMEPAGE = "http://github.com/matplotlib/cycler"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7713fe42cd766b15c710e19392bfa811"
+
+SRC_URI[md5sum] = "4cb42917ac5007d1cdff6cccfe2d016b"
+SRC_URI[sha256sum] = "cd7b2d1018258d7247a71425e9f26463dfb444d411c39569972f4ce586b0c9d8"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-lang ${PYTHON_PN}-six"
diff --git a/meta-python/recipes-devtools/python/python-cycler_0.10.0.bb b/meta-python/recipes-devtools/python/python-cycler_0.10.0.bb
new file mode 100644
index 0000000000..ef2ca4cb90
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cycler_0.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-cycler.inc
diff --git a/meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb b/meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb
new file mode 100644
index 0000000000..3a943c0f67
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cycler_0.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-cycler.inc