aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend')
-rw-r--r--meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend b/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
index 0fa7f97610..fb31f9234d 100644
--- a/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
+++ b/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
@@ -7,6 +7,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://rpcbind.service"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "rpcbind.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "rpcbind.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
+}