aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend
new file mode 100644
index 0000000000..d9ad9ba2a5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.2p2.bbappend
@@ -0,0 +1,19 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SYSTEMD_PACKAGES = "${PN}-sshd"
+SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
+FILES_${PN}-sshd += "${systemd_unitdir}/system/sshd.socket"
+RPROVIDES_${PN}-sshd += "${PN}-sshd-systemd"
+RREPLACES_${PN}-sshd += "${PN}-sshd-systemd"
+RCONFLICTS_${PN}-sshd += "${PN}-sshd-systemd"
+
+inherit systemd
+
+SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
+}
+