aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index c0276a391b..281c44043b 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -4,8 +4,14 @@ PRINC := "${@int(PRINC) + 1}"
inherit systemd
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "portmap.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "portmap.service"
SYSTEMD_AUTO_ENABLE = "disable"
SRC_URI_append = " file://portmap.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
+}
+